Bug 620866 - RH-Personal, Product names should match for the initial pool
RH-Personal, Product names should match for the initial pool
Status: CLOSED NOTABUG
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
All Solaris
low Severity medium
: ---
: ---
Assigned To: Bryan Kearney
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 12:32 EDT by wes hayutin
Modified: 2015-05-14 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-10 14:40:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-08-03 12:32:50 EDT
[root@client01-rhel6-beta2 src]# ./subscription-manager-cli register --username=test2 --pass=redhat --type=person
d6277af3-a2f3-495d-8ac5-efa6676adffe test2
[root@client01-rhel6-beta2 src]# ./subscription-manager-cli list --available
d6277af3-a2f3-495d-8ac5-efa6676adffe
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Personal Edition with Unlimited Virtualization
ProductId:         	RH1187309                
PoolId:            	618                      
Quantity:          	3                        
Expires:           	2011-07-20               

[root@client01-rhel6-beta2 src]# ./subscription-manager-cli subscribe --pool=618
[root@client01-rhel6-beta2 src]# ./subscription-manager-cli list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Red Hat Enterprise Linux Server
ContractNumber:     	1935551                  
SerialNumber:       	1247                     
Active:             	True                     
Begins:             	2010-08-03               
Expires:            	2011-07-20
Comment 1 Mike Orazi 2010-08-03 12:51:41 EDT
The subscription is to RH1187309, which is a configured SKU.  There will be multiple SKUs of that nature, which all point to something that will have a product name of 'Red Hat Enterprise Linux Server'.

This is as intended, but I agree it is a bit confusing.
Comment 2 wes hayutin 2010-08-03 12:59:33 EDT
I would agree for the second step the above naming convention makes sense. However for the first step, which from my understanding is a temporary step until the web app for RH-Personal is created; it does not make sense.

On the on-premises candlepin after the first subscribe command, the naming conventions make more sense.  The product name is "Red Hat Personal bits"

That may not be a name you want to work with, but I certainly have not consumed a RHEL entitlement after the first subscribe command. For sanity sake, I think we should change it.
Comment 3 wes hayutin 2010-08-03 13:02:45 EDT
Can QE please get a link to the design that would illustrate the naming conventions that will be used for RH-Personal.  One that illustrates its use before and after the RH-Personal web app is available would be ideal.
Comment 4 Mike Orazi 2010-08-03 16:38:27 EDT
We can work together to get a doc in place to describe how to determine the product name/oid from the database.  I think that will get you the info that you need.  

The naming conventions themselves aren't really owned by this group though.
Comment 5 Mark Sechrest 2010-08-19 09:29:00 EDT
BK: I think the only way to "fix" this is to add some logic to the cert generation to swap the name when you have a sub-pool. Thoughts?
Comment 6 Bryan Kearney 2010-09-10 14:40:54 EDT
Per the new model, I am closing this as not a bug. Ops is planning to purchase RHEL personal, but consume RHEL server.

Note You need to log in before you can comment on or make changes to this bug.