Bug 620887 - RHUA log files should automatically rotate
Summary: RHUA log files should automatically rotate
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA   
(Show other bugs)
Version: 1.1
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: Jay Dobies
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-03 17:21 UTC by Jay Dobies
Modified: 2012-05-31 12:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 12:55:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Dobies 2010-08-03 17:21:17 UTC
The two primary log files for the RHUA, /var/log/rhua.log and /var/log/grinder.log, currently have no upper boundary on their size. Since these get output each time "rhua update" runs, these need to be changed to be rotating file handlers to prevent their size from being unbounded.

Comment 1 Jay Dobies 2010-08-03 17:25:57 UTC
commit	ab04e5223ae3e8248f76bfb9a7e9833b58fa83f0
tree	ce5d06a1cc4e8118bba4113b15d9397f4773aea5


620887 - Changed log file handlers to automatically rotate based on a configurable size.


rhui/rhua/etc/rhua/rhua.yml
rhui/rhua/src/rhua/cli.py
rhui/rhua/src/rhua/utils.py

Comment 2 wes hayutin 2010-08-16 18:29:39 UTC
[root@ip-10-194-145-203 yum.repos.d]# ls /var/log/rhua/rhua.log*
/var/log/rhua/rhua.log  /var/log/rhua/rhua.log.1  /var/log/rhua/rhua.log.2  /var/log/rhua/rhua.log.3  /var/log/rhua/rhua.log.4
[root@ip-10-194-145-203 yum.repos.d]# 

log_rhua_file : '/var/log/rhua/rhua.log'
log_grinder_file : '/var/log/rhua/grinder.log'
#log_max_bytes : 1048576
log_max_bytes : 104

Comment 3 wes hayutin 2011-08-01 21:39:46 UTC
moving to release pending

Comment 4 wes hayutin 2012-05-31 12:55:04 UTC
closing out, product released


Note You need to log in before you can comment on or make changes to this bug.