Bug 620924 - /sbin/mount.tmpfs uses not available /usr/bin/id
/sbin/mount.tmpfs uses not available /usr/bin/id
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
: 623545 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 15:11 EDT by Piergiorgio Sartor
Modified: 2010-09-01 01:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: util-linux-ng-2.18-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 621389 (view as bug list)
Environment:
Last Closed: 2010-08-12 00:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2010-08-03 15:11:02 EDT
Description of problem:
On boot, /sbin/mount.tmpfs is called by some scripts.
This uses /usr/bin/id, but at boot time, in the position where /sbin/mount.tmpfs is called, it might not be available, if /usr is on a separate partition (mounted later, I guess).

Version-Release number of selected component (if applicable):
util-linux-ng-2.17.2-6.fc13

How reproducible:
Always, if /usr is separate, and tmpfs is used (I guess always).

Steps to Reproduce:
1.
Boot
2.
Check the printout
  
Actual results:
An error is reported by /sbin/mount.tmpfs not finding "id".

Expected results:
No error.

Additional info:
Just a note.
This type of failure, something called at boot which is in /usr, seems to be quite common (already several bugs reported on this condition).

Maybe there should be a checklist somewhere, including "make sure there is no reference to /usr" or similar.

Thanks,

bye,

pg
Comment 1 Fedora Update System 2010-08-05 07:41:32 EDT
util-linux-ng-2.17.2-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/util-linux-ng-2.17.2-8.fc13
Comment 2 Fedora Update System 2010-08-05 07:42:28 EDT
util-linux-ng-2.18-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/util-linux-ng-2.18-3.fc14
Comment 3 Fedora Update System 2010-08-05 10:24:16 EDT
util-linux-ng-2.18-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update util-linux-ng'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/util-linux-ng-2.18-3.fc14
Comment 4 Fedora Update System 2010-08-05 19:28:35 EDT
util-linux-ng-2.17.2-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update util-linux-ng'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/util-linux-ng-2.17.2-8.fc13
Comment 5 Fedora Update System 2010-08-12 00:08:18 EDT
util-linux-ng-2.17.2-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ondrej Vasik 2010-08-12 09:18:48 EDT
*** Bug 623545 has been marked as a duplicate of this bug. ***
Comment 7 Bruce Jerrick 2010-08-16 04:03:53 EDT
I apologize for submitting a duplicate bug report.  I did search, but at
that time the signal-to-noise ratio was just terrible.  The recent bugzilla
upgrade seems to be a tremendous improvement.
-- Bruce Jerrick
Comment 8 Fedora Update System 2010-08-18 04:38:14 EDT
util-linux-ng-2.18-4.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/util-linux-ng-2.18-4.fc14
Comment 9 Fedora Update System 2010-09-01 01:47:52 EDT
util-linux-ng-2.18-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.