Bug 621001 - Unable to boot new kernel 2.6.33.6-147.2.4.fc13.x86_64 for fedora 13
Unable to boot new kernel 2.6.33.6-147.2.4.fc13.x86_64 for fedora 13
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
13
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Reopened
: 621344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 18:54 EDT by Michael D Parker
Modified: 2010-08-05 02:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 15:59:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael D Parker 2010-08-03 18:54:27 EDT
Description of problem:

After starting the boot process, I get the message

dracut: FATAL: osr: Cannot find parameter file /tmp/osr.nodeid.  This parameter is required and not set.
dracut: Refusing to continue

Signal caught!

Boot has failed, sleeping forever.


Version-Release number of selected component (if applicable):


How reproducible:
happens always

Steps to Reproduce:
1. simply install the 2.2.6.33.6-147.2.4.fc13.x86_64 kernel package
3.
  
Actual results:


Expected results:
The kernel 2.2.6.33-147 continues to boot just fine.

Additional info:
Comment 1 Harald Hoyer 2010-08-04 04:12:42 EDT
You installed osr-dracut-module-cluster ...

Why did you do that? Do you have an osr cluster? 
If yes, you have to configure the cluster.

If you don't have an osr cluster and blindly installed all packages with "dracut" in the name, then:

# yum remove osr-dracut-module osr-dracut-module-chroot \
  osr-dracut-module-cluster dracut-fips dracut-modules-olpc 

and recreate your initramfs image

# dracut -f /boot/initramfs-2.2.6.33.6-147.2.4.fc13.x86_64.img \
  2.2.6.33.6-147.2.4.fc13.x86_64
Comment 2 Michael D Parker 2010-08-04 15:41:22 EDT
*** Bug 621344 has been marked as a duplicate of this bug. ***
Comment 3 Michael D Parker 2010-08-04 15:51:22 EDT
I tried your suggestions and I still get the same result at reboot.
Comment 4 Michael D Parker 2010-08-04 15:59:05 EDT
There were typos in the command line as given by Mr. Hoyer.  The recreate of the initramfs image should be edited as follows :  s/2.2.6/2.6/g

Things now work correctly.
Comment 5 Harald Hoyer 2010-08-05 02:53:18 EDT
(In reply to comment #4)
> There were typos in the command line as given by Mr. Hoyer.  The recreate of
> the initramfs image should be edited as follows :  s/2.2.6/2.6/g
> 

sorry, I blindly copy & pasted the version from comment 1

Note You need to log in before you can comment on or make changes to this bug.