Bug 621046 - kernel IRQ 18 nobody cared lost interrupt
Summary: kernel IRQ 18 nobody cared lost interrupt
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 06:00 UTC by Jasper O'neal Hartline
Modified: 2010-08-19 10:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 10:45:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jasper O'neal Hartline 2010-08-04 06:00:08 UTC
Description of problem:
Aug  3 22:34:25 localhost kernel: NVRM: Xid (0005:00): 16, Head 00000001 Count 00000000
Aug  3 22:34:26 localhost kernel: NVRM: Xid (0005:00): 16, Head 00000000 Count 00000003
Aug  3 22:34:36 localhost kernel: NVRM: Xid (0005:00): 8, Channel 0000007f
Aug  3 22:34:36 localhost kernel: NVRM: os_pci_init_handle: invalid context!
Aug  3 22:34:36 localhost kernel: NVRM: os_pci_init_handle: invalid context!
Aug  3 22:34:41 localhost kernel: irq 18: nobody cared (try booting with the "irqpoll" option)
Aug  3 22:34:41 localhost kernel: Pid: 0, comm: swapper Tainted: P           2.6.33.6-147.fc13.i686 #1
Aug  3 22:34:41 localhost kernel: Call Trace:
Aug  3 22:34:41 localhost kernel: [<c0479f86>] __report_bad_irq+0x2e/0x6f
Aug  3 22:34:41 localhost kernel: [<c047a0bc>] note_interrupt+0xf5/0x14d
Aug  3 22:34:41 localhost kernel: [<c047a66f>] handle_fasteoi_irq+0x85/0xa4
Aug  3 22:34:41 localhost kernel: [<c0404cd3>] handle_irq+0x3b/0x48
Aug  3 22:34:41 localhost kernel: [<c0404558>] do_IRQ+0x41/0x9a
Aug  3 22:34:41 localhost kernel: [<c0403830>] common_interrupt+0x30/0x38
Aug  3 22:34:41 localhost kernel: [<c0457814>] ? tick_nohz_stop_sched_tick+0x34d/0x377
Aug  3 22:34:41 localhost kernel: [<c0402496>] cpu_idle+0x6f/0xad
Aug  3 22:34:41 localhost kernel: [<c076c715>] start_secondary+0x1f5/0x233
Aug  3 22:34:41 localhost kernel: handlers:
Aug  3 22:34:41 localhost kernel: [<f7ee9b5c>] (snd_emu10k1_interrupt+0x0/0x434 [snd_emu10k1])
Aug  3 22:34:41 localhost kernel: [<f8eea954>] (nv_kern_isr+0x0/0x54 [nvidia])
Aug  3 22:34:41 localhost kernel: Disabling IRQ #18
Aug  3 22:35:13 localhost kernel: ata4: lost interrupt (Status 0x50)
Aug  3 22:35:13 localhost kernel: VFS: busy inodes on changed media or resized disk sr1
Aug  3 22:35:44 localhost kernel: ata4: lost interrupt (Status 0x51)
Aug  3 22:35:49 localhost kernel: ata4.00: qc timeout (cmd 0xa0)
Aug  3 22:35:49 localhost kernel: ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
Aug  3 22:35:49 localhost kernel: sr 3:0:0:0: CDB: Test Unit Ready: 00 00 00 00 00 00
Aug  3 22:35:49 localhost kernel: ata4.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
Aug  3 22:35:49 localhost kernel:         res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x5 (timeout)
Aug  3 22:35:49 localhost kernel: ata4.00: status: { DRDY ERR }
Aug  3 22:35:49 localhost kernel: ata4: soft resetting link
Aug  3 22:35:50 localhost kernel: ata4.00: configured for MWDMA2
Aug  3 22:35:50 localhost kernel: ata4.01: configured for UDMA/33
Aug  3 22:35:55 localhost kernel: ata4.00: qc timeout (cmd 0xa0)
Aug  3 22:35:55 localhost kernel: ata4.00: TEST_UNIT_READY failed (err_mask=0x5)
Aug  3 22:35:55 localhost kernel: ata4: soft resetting link
Aug  3 22:35:55 localhost kernel: ata4.00: configured for MWDMA2
Aug  3 22:35:55 localhost kernel: ata4.01: configured for UDMA/33
Aug  3 22:36:00 localhost kernel: ata4.00: qc timeout (cmd 0xa0)
Aug  3 22:38:15 localhost kernel: imklog 4.4.2, log source = /proc/kmsg started.
Aug  3 22:38:15 localhost rsyslogd: [origin software="rsyslogd" swVersion="4.4.2" x-pid="1737" x-info="http://www.rsyslog.com
"] (re)start
Aug  3 22:38:15 localhost kernel: Initializing cgroup subsys cpuset
Aug  3 22:38:15 localhost kernel: Initializing cgroup subsys cpu
Aug  3 22:38:15 localhost kernel: Linux version 2.6.33.6-147.fc13.i686 (mockbuild@x86-14.phx2.fedoraproject.org) (gcc version
 4.4.4 20100630 (Red Hat 4.4.4-10) (GCC) ) #1 SMP Tue Jul 6 22:30:55 UTC 2010
Aug  3 22:38:15 localhost kernel: BIOS-provided physical RAM map:
Aug  3 22:38:15 localhost kernel: BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 00000000000e9000 - 0000000000100000 (reserved)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 0000000000100000 - 000000007ffe0000 (usable)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 000000007ffe0000 - 000000007ffee000 (ACPI data)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 000000007ffee000 - 000000007fff0000 (ACPI NVS)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 000000007fff0000 - 0000000080000000 (reserved)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
Aug  3 22:38:15 localhost kernel: BIOS-e820: 00000000ff700000 - 0000000100000000 (reserved)
Aug  3 22:38:15 localhost kernel: Notice: NX (Execute Disable) protection cannot be enabled: non-PAE kernel!
Aug  3 22:38:15 localhost kernel: DMI 2.3 present.
Aug  3 22:38:15 localhost kernel: AMI BIOS detected: BIOS may corrupt low RAM, working around it.
Aug  3 22:38:15 localhost kernel: last_pfn = 0x7ffe0 max_arch_pfn = 0x100000

Version-Release number of selected component (if applicable):
kernel-2.6.33.6-147.fc13.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chuck Ebbert 2010-08-19 01:21:57 UTC
This looks like a problem with the nvidia drivers. Does it happen if you use nouveau instead?

Comment 2 Jasper O'neal Hartline 2010-08-19 02:48:49 UTC
No it sure does not.
I figured I would file even though it does look related to nVidia.

Comment 3 Chuck Ebbert 2010-08-19 10:45:35 UTC
You should report the problem to nvidia.


Note You need to log in before you can comment on or make changes to this bug.