Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621094 - Client is able to install package even after "rhua destroy"
Client is able to install package even after "rhua destroy"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
1.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 04:45 EDT by Shveta
Modified: 2012-05-31 08:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 08:53:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shveta 2010-08-04 04:45:36 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
 On RHUA

[root@ip-10-204-149-10 os]# rhua destroy
========================================
RHUA Destroy

Stopping daemons
Removing update cron entry from [/etc/cron.d/rhua_update.cron]
Removing monitor cron entry from [/etc/cron.d/rhua_monitor.cron]
Cleaning up synchronized packages
Deleting package directory [/mnt/content]
Cleaning up mirror lists
Deleting mirror list directory [/var/www/html/pub/]
========================================
[root@ip-10-204-149-10 os]# cd /var/www/html/
[root@ip-10-204-149-10 html]# ll
total 8
-rw-r--r-- 1 root root 1566 Aug  4 04:40 feed.rss
=============================================
vi /var/log/rhua.log


2010-08-04 04:38:06,281  ========================================
2010-08-04 04:38:06,282  RHUA Destroy
2010-08-04 04:38:06,282
2010-08-04 04:38:06,282  Stopping daemons
2010-08-04 04:38:06,282  Removing update cron entry from [/etc/cron.d/rhua_update.cron]
2010-08-04 04:38:06,283  Removing monitor cron entry from [/etc/cron.d/rhua_monitor.cron]
2010-08-04 04:38:06,283  Cleaning up synchronized packages
2010-08-04 04:38:06,283  Deleting package directory [/mnt/content]
2010-08-04 04:38:08,898  Testing yum [yum --disablerepo=* --enablerepo=repo-ec2-174-129-160-231.compute-1.amazonaws.com repolist]
2010-08-04 04:38:09,048  Cleaning up mirror lists
2010-08-04 04:38:09,049  Deleting mirror list directory [/var/www/html/pub/]
2010-08-04 04:38:09,050  ========================================
2010-08-04 04:38:15,802  Testing yum [yum --disablerepo=* --enablerepo=repo-ec2-174-129-160-231.compute-1.amazonaws.com repolist]
2010-08-04 04:38:16,400  Testing yum [yum --disablerepo=* --enablerepo=repo-ec2-174-129-160-231.compute-1.amazonaws.com repolist]

ON Client:

[root@ip-10-204-151-54 noarch]# yum search zsh
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
================================= Matched: zsh =================================
zsh.x86_64 : A powerful interactive shell
zsh-html.x86_64 : Zsh shell manual in html format
[root@ip-10-204-151-54 noarch]# yum install zsh.x86_64
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package zsh.x86_64 0:4.2.6-3.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch             Version                  Repository        Size
================================================================================
Installing:
 zsh           x86_64           4.2.6-3.el5              rhel-5           1.7 M

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 1.7 M
Is this ok [y/N]: y
Downloading Packages:
zsh-4.2.6-3.el5.x86_64.rpm                               | 1.7 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : zsh                                                      1/1 

Installed:
  zsh.x86_64 0:4.2.6-3.el5                                                      

Complete!
[root@ip-10-204-151-54 noarch]# vi /etc/yum.repos.d/
[root@ip-10-204-151-54 noarch]# cd /etc/yum.repos.d/
[root@ip-10-204-151-54 yum.repos.d]# ll
total 24
-rw-r--r-- 1 root root 463 Aug  4 01:53 redhat-us-east.repo.rpmsave
-rw-r--r-- 1 root root 436 Aug  4 03:23 rh-cloud.repo
-rw-r--r-- 1 root root 561 Mar 10 09:21 rhel-debuginfo.repo
[root@ip-10-204-151-54 yum.repos.d]# vi rh-cloud.repo 
[root@ip-10-204-151-54 yum.repos.d]# yum search emacs
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
================================ Matched: emacs ================================
anthy.i386 : Japanese character set input library
anthy.x86_64 : Japanese character set input library
anthy-el.x86_64 : Emacs Lisp files to use Anthy on Emacs
compat-readline43.i386 : The readline 4.3 library for compatibility with older
                       : software.
compat-readline43.x86_64 : The readline 4.3 library for compatibility with older
                         : software.
ctags.x86_64 : A C programming language indexing and/or cross-reference tool.
dtach.x86_64 : A simple program that emulates the detach feature of screen.
ed.x86_64 : The GNU line editor.
emacs.x86_64 : GNU Emacs text editor
emacs-common.x86_64 : Emacs common files
emacs-el.x86_64 : Emacs Lisp source files included with Emacs.
emacs-leim.x86_64 : Emacs Lisp files for input methods for international
                  : characters.
emacs-nox.x86_64 : GNU Emacs text editor without X support
emacspeak.noarch : emacspeak -- The Complete Audio Desktop
gnuplot-emacs.x86_64 : Emacs bindings for the gnuplot main application
gpm.i386 : A mouse server for the Linux console.
gpm.x86_64 : A mouse server for the Linux console.
gpm-devel.i386 : A mouse server for the Linux console.
gpm-devel.x86_64 : A mouse server for the Linux console.
psgml.noarch : A GNU Emacs major mode for editing SGML documents.
readline.i386 : A library for editing typed command lines.
readline.x86_64 : A library for editing typed command lines.
ruby-mode.x86_64 : Emacs Lisp ruby-mode for the scripting language Ruby
[root@ip-10-204-151-54 yum.repos.d]# yum install emacs.x86_64
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emacs.x86_64 0:21.4-20.el5 set to be updated
--> Processing Dependency: emacs-common = 21.4-20.el5 for package: emacs
--> Processing Dependency: xorg-x11-fonts-ISO8859-1-75dpi for package: emacs
--> Processing Dependency: libungif.so.4()(64bit) for package: emacs
--> Processing Dependency: libXaw3d.so.7()(64bit) for package: emacs
--> Processing Dependency: libgif.so.4()(64bit) for package: emacs
--> Running transaction check
---> Package Xaw3d.x86_64 0:1.5E-10.1 set to be updated
---> Package emacs-common.x86_64 0:21.4-20.el5 set to be updated
---> Package giflib.x86_64 0:4.1.3-7.1.el5_3.1 set to be updated
---> Package xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.1-2.1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                          Arch     Version               Repository
                                                                           Size
================================================================================
Installing:
 emacs                            x86_64   21.4-20.el5           rhel-5   1.7 M
Installing for dependencies:
 Xaw3d                            x86_64   1.5E-10.1             rhel-5   155 k
 emacs-common                     x86_64   21.4-20.el5           rhel-5    11 M
 giflib                           x86_64   4.1.3-7.1.el5_3.1     rhel-5    39 k
 xorg-x11-fonts-ISO8859-1-75dpi   noarch   7.1-2.1.el5           rhel-5   933 k

Transaction Summary
================================================================================
Install       5 Package(s)
Upgrade       0 Package(s)

Total download size: 13 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): giflib-4.1.3-7.1.el5_3.1.x86_64.rpm               |  39 kB     00:00     
(2/5): Xaw3d-1.5E-10.1.x86_64.rpm                        | 155 kB     00:00     
(3/5): xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5.noarch | 933 kB     00:00     
(4/5): emacs-21.4-20.el5.x86_64.rpm                      | 1.7 MB     00:00     
(5/5): emacs-common-21.4-20.el5.x86_64.rpm               |  11 MB     00:01     
--------------------------------------------------------------------------------
Total                                           8.0 MB/s |  13 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : emacs-common                                             1/5 
  Installing     : Xaw3d                                                    2/5 
  Installing     : giflib                                                   3/5 
  Installing     : xorg-x11-fonts-ISO8859-1-75dpi                           4/5 
  Installing     : emacs                                                    5/5 

Installed:
  emacs.x86_64 0:21.4-20.el5                                                    

Dependency Installed:
  Xaw3d.x86_64 0:1.5E-10.1                                                      
  emacs-common.x86_64 0:21.4-20.el5                                             
  giflib.x86_64 0:4.1.3-7.1.el5_3.1                                             
  xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.1-2.1.el5                           

Complete!
[root@ip-10-204-151-54 yum.repos.d]# 

==================================================

http://ec2-174-129-159-241.compute-1.amazonaws.com/pub/content/dist/rhel/server/5Server/ 

Not available .
Comment 1 Jay Dobies 2010-08-04 09:59:57 EDT
I think the issue is that yum holds on to a cached version of the mirror list:

"Loading mirror speeds from cached hostfile"

Regardless, "destroy" doesn't actually do anything to the CDS instances since deltacloud isn't installed. So if the client were to circumvent the mirrorlist and go directly to the CDS, everything is still running successfully.

We need a call in here to wipe the packages off of the CDS in order to keep the "destroy" type functionality.
Comment 2 Jay Dobies 2010-08-04 10:43:31 EDT
commit	3b96989adb815eb71527eab7a49c8dcd2a11eed1
tree	437e97a2abd7809701f61b685fd1612576b3da14


621094 - Added call to remove all packages from the CDS on an environment destroy.


rhui/rhua/src/rhua/cds_ops.py
rhui/rhua/src/rhua/rhua.py
Comment 3 wes hayutin 2010-08-04 16:40:09 EDT
[root@domU-12-31-39-00-17-F2 log]# rhua destroy
========================================
RHUA Destroy

Stopping daemons
Removing update cron entry from [/etc/cron.d/rhua_update.cron]
Removing monitor cron entry from [/etc/cron.d/rhua_monitor.cron]
Cleaning the CDS instances
Output from SSH command [/usr/bin/ssh -oChallengeResponseAuthentication=no -oStrictHostKeyChecking=no -i /etc/rhua/cloude-key.pem  root@ec2-174-129-142-43.compute-1.amazonaws.com "/bin/bash --login -c \"rm -Rf /mnt/content/*\""]

Output from SSH command [/usr/bin/ssh -oChallengeResponseAuthentication=no -oStrictHostKeyChecking=no -i /etc/rhua/cloude-key.pem  root@ec2-174-129-191-186.compute-1.amazonaws.com "/bin/bash --login -c \"rm -Rf /mnt/content/*\""]

Cleaning up synchronized packages
Deleting package directory [/mnt/content]
Cleaning up mirror lists
Deleting mirror list directory [/var/www/html/pub/]


CDS

[root@domU-12-31-39-0E-40-31 content]# pwd
/mnt/content
[root@domU-12-31-39-0E-40-31 content]# ls

[root@domU-12-31-39-0F-60-22 ~]# ls /mnt/content/
[root@domU-12-31-39-0F-60-22 ~]#
Comment 4 wes hayutin 2011-08-01 17:39:23 EDT
moving to release pending
Comment 5 wes hayutin 2012-05-31 08:53:48 EDT
closing out, product released

Note You need to log in before you can comment on or make changes to this bug.