Bug 62110 - wrong character set for gnome menu items in kde
wrong character set for gnome menu items in kde
Status: CLOSED DUPLICATE of bug 62843
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-27 11:18 EST by Leonid Kanter
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-06 12:43:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2002-03-27 11:18:51 EST
Description of Problem:

Looks like bug 51643 is re-implemented in kde3 from beta3, but in new kind: it
currently use iso8859-1 font for non-utf8 menu items (gnome and
/etc/X11/applnk), while must use font in `locale charmap` encoding (KOI8-R in my
case).

Version-Release number of selected component (if applicable):

kdebase-3.0.0-0.cvs20020314.4

How Reproducible:

always

Steps to Reproduce:
1. set LANG=ru_RU.koi8r
2. start kde
3. select Russia, Russian language

Actual Results:

All gnome menu items will be displayed by iso-8859-1 characters.

Expected Results:

For gnome menu must be used the same font which is used for native kde menu
items (cyrillic characters in this case)
Comment 1 Bernhard Rosenkraenzer 2002-03-28 07:58:00 EST
This is because GNOME doesn't honor the desktop files standard, which clearly 
states desktop files must use UTF-8 encoding.
Comment 2 Havoc Pennington 2002-03-28 08:47:24 EST
No it doesn't state that. It states that .desktop files may use either UTF-8 or
Legacy-Mixed encoding. Read the spec.
Comment 3 Leonid Kanter 2002-04-06 12:43:33 EST
I'm unable to reproduce the bug in beta4 (kdebase-3.0.0-3). Everything is OK
with GNOME menu.
Comment 4 Bernhard Rosenkraenzer 2002-04-10 12:35:25 EDT

*** This bug has been marked as a duplicate of 62843 ***

Note You need to log in before you can comment on or make changes to this bug.