Bug 621116 - v2v detects remote libvirt volume as 0 size
Summary: v2v detects remote libvirt volume as 0 size
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
high
high
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: RHELNAK
Depends On: 620698
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 09:58 UTC by Rita Wu
Modified: 2013-07-03 01:41 UTC (History)
10 users (show)

Fixed In Version: virt-v2v-0.6.3-1.el5
Doc Type: Bug Fix
Doc Text:
Previously, the virt-v2v package incorrectly detected the size of a guest which uses local block devices for storage when transferring data over SSH, which caused the storage transfer to fail. This update fixes this issue and the size of guests is correctly detected.
Story Points: ---
Clone Of: 620698
Environment:
Last Closed: 2011-01-13 18:28:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0147 normal SHIPPED_LIVE virt-v2v and libguestfs bug fix update 2011-01-13 18:28:09 UTC

Comment 1 RHEL Product and Program Management 2010-09-05 07:57:49 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 2 Matthew Booth 2010-09-06 09:48:10 UTC
This is already upstream.

Comment 3 RHEL Product and Program Management 2010-09-06 09:57:00 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2010-09-07 11:57:01 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 6 koka xiong 2010-10-09 06:21:45 UTC
Verified with virt-v2v-0.6.3-2.el5 failed
1. virsh -c xen+ssh://10.66.93.217 dumpxml test
root@10.66.93.217's password: 
<domain type='xen'>
  <name>test</name>
  <uuid>ce19c40d-fed1-a5af-6859-6497d8927a0c</uuid>
  <memory>524288</memory>
  <currentMemory>524288</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='xenfv'>hvm</type>
    <loader>/usr/lib/xen/boot/hvmloader</loader>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/lib64/xen/bin/qemu-dm</emulator>
    <disk type='block' device='disk'>
      <driver name='phy'/>
      <source dev='/dev/mapper/VolGroup00-koka'/>
      <target dev='hda' bus='ide'/>
    </disk>
    <interface type='bridge'>
      <mac address='00:16:36:58:8c:a0'/>
      <source bridge='xenbr0'/>
      <script path='vif-bridge'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target port='0'/>
    </console>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' keymap='en-us'/>
  </devices>
</domain>

2.lvs[root@dhcp-93-217 ~]# lvs
  LV       VG         Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  LogVol00 VolGroup00 -wi-a-  48.81G                                      
  LogVol01 VolGroup00 -wi-ao   9.50G                                      
  LogVol02 VolGroup00 -wi-ao  48.81G                                      
  LogVol03 VolGroup00 -wi-ao 120.00G                                      
  koka     VolGroup00 -wi-a-  10.00G                                      
  pv_lvm   VolGroup00 -wi-a-   6.00G  

3.Run virt-v2v -ic xen+ssh://10.66.93.217 -o rhev -osd 10.66.90.115:/vol/v2vrwu1/xen_export test
root@10.66.93.217's password: 
root@10.66.93.217's password: 
virt-v2v: test configured with virtio drivers
virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vrwu1/xen_export. Command exited with status 1. Output was: umount: /tmp/vj5ChvfRmn: device is busy
umount: /tmp/vj5ChvfRmn: device is busy

virt-v2v: Failed to remove mount directory /tmp/vj5ChvfRmn: Device or resource busy

Comment 7 Matthew Booth 2010-10-11 09:11:05 UTC
(In reply to comment #6)
> virt-v2v: test configured with virtio drivers

^^^ It looks like the test succeeded.

> virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vrwu1/xen_export. Command
> exited with status 1. Output was: umount: /tmp/vj5ChvfRmn: device is busy
> umount: /tmp/vj5ChvfRmn: device is busy
> 
> virt-v2v: Failed to remove mount directory /tmp/vj5ChvfRmn: Device or resource
> busy

^^^ These warning messages are a different bug.

I believe this bug should be VERIFIED. I'll put it straight back to MODIFIED in any case.

Comment 8 Rita Wu 2010-10-11 10:04:18 UTC
Verified with virt-v2v-0.6.3-2.el5+libvirt-0.8.2-6.el5+libguestfs-1.2.7-1.el5.8

#  virt-v2v -ic xen+ssh://10.66.93.217 -o rhev -osd 10.66.90.115:/vol/v2vrwu1/xen_export test
root@10.66.93.217's password: 
root@10.66.93.217's password: 
open /dev/kvm: No such file or directory
Could not initialize KVM, will disable KVM support
virt-v2v: WARNING: No mapping found for bridge interface xenbr0 in config file. The converted guest may not start until its network interface is updated.
virt-v2v: test configured with virtio drivers
[root@dhcp-93-224 ~]# echo $?
0

Comment 9 Florian Nadge 2011-01-12 17:30:12 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the virt-v2v package incorrectly detected the size of a guest which uses local block devices for storage when transferring data over SSH, which caused the storage transfer to fail. This update fixes this issue and the size of guests is correctly detected.

Comment 11 errata-xmlrpc 2011-01-13 18:28:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0147.html


Note You need to log in before you can comment on or make changes to this bug.