Bug 621128 - “consumed list “ does not displayed subscribed product
Summary: “consumed list “ does not displayed subscribed product
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 568421
TreeView+ depends on / blocked
 
Reported: 2010-08-04 10:50 UTC by spandey
Modified: 2015-04-23 23:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:41:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm.log (447.89 KB, application/octet-stream)
2010-08-04 10:51 UTC, spandey
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description spandey 2010-08-04 10:50:15 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Prerequisites
Candlepin : candlepin1.devlab.phx1.redhat.com
Client : Rhel6 client with sm version 74

Steps to repro : 
Register client to candlepin1 using user tmgedp 
subscribe pool id 519 
execute list --consumed for listing subscribed product 

Expected Result : 
“list --consumed “ command should display subscribed product 

Actual Reuslt : 
[root@sachrhel6 ~]# subscription-manager-cli list --consumed

No Consumed subscription pools to list

subscribe entitlement cert is getting recored in rhsm.log file 
command “subscription-manager-cli list” displays subscribed product 

[root@sachrhel6 ~]# subscription-manager-cli list

+-------------------------------------------+

    Installed Product Status

+-------------------------------------------+



ProductName:        	Red Hat Enterprise Linux for HPC Compute Nodes, Basic (Up to 2 Sockets) (Legacy SVC0384)

Status:             	Not Installed            

Expires:            	2011-12-31               

Subscription:       	1284                     

ContractNumber:        	1458961         

Attached rhsm.log

Comment 1 spandey 2010-08-04 10:51:26 UTC
Created attachment 436496 [details]
rhsm.log

Comment 3 RHEL Product and Program Management 2010-08-04 11:08:01 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Ajay Kumar Nadathur Sreenivasan 2010-09-01 17:17:39 UTC
duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=622596

Comment 5 spandey 2010-09-08 12:59:43 UTC
Environment:

candlepin1
client : rhel6 with sm version 75 

subscribed product RHN provisioning 

consumed list displays subscribed product 

  [root@sachrhel6 ~]# subscription-manager-cli subscribe --pool=650
[root@sachrhel6 ~]# subscription-manager-cli list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	RHN Provisioning + Management (Legacy SVC0081)
ContractNumber:     	1458961                  
SerialNumber:       	4486                     
Active:             	True                     
Begins:             	2009-01-01               
Expires:            	2011-12-31               

[root@sachrhel6 ~]# ls /etc/pki/entitlement/product/
4486.pem



Still cert private key is getting recorded in rhsm.log so think this defect is not resolved 

so i am moving defect status from ON_QA to ON_DEV

Comment 6 spandey 2010-09-08 13:54:17 UTC
Sorry for reopening this defect 

we already have defect for private key getting displayed in rhsm.log 

627915

So i am resolving defect as verified

Comment 8 errata-xmlrpc 2011-05-19 13:41:57 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.