Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621158 - RFE: plymouth password prompt for non-LUKS cryptodev [patch included]
RFE: plymouth password prompt for non-LUKS cryptodev [patch included]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 08:12 EDT by Ralf Ertzinger
Modified: 2014-03-16 23:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-28 14:47:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/rc.sysinit (854 bytes, patch)
2010-08-04 08:12 EDT, Ralf Ertzinger
no flags Details | Diff

  None (edit)
Description Ralf Ertzinger 2010-08-04 08:12:57 EDT
Created attachment 436508 [details]
Patch for /etc/rc.sysinit

Description of problem:
Currently /etc/rc.sysinit switches back to a text console to query for the passphrase for non-LUKS cryptodev devices in /etc/crypttab. The attached patch changes this to use the plymouth password prompt.

Version-Release number of selected component (if applicable):
initscripts-9.12.1-1.fc13.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2011-02-28 14:47:20 EST
Added to devel & F-14 branches, thanks! (Sorry about the delay.)
Comment 2 Ralf Ertzinger 2011-04-10 10:38:53 EDT
Sorry to bring this up again, but the change does not seem to be in F14.

Note You need to log in before you can comment on or make changes to this bug.