Bug 621161 - qemu-kvm crashes with I/O Possible message
Summary: qemu-kvm crashes with I/O Possible message
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
: 614915 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 12:16 UTC by Lubos Kocman
Modified: 2013-01-09 22:59 UTC (History)
7 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.109.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:27:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of qemu-kvm (3.76 MB, text/plain)
2010-08-04 12:16 UTC, Lubos Kocman
no flags Details
qemu-kvm output (1.91 KB, text/plain)
2010-08-04 12:17 UTC, Lubos Kocman
no flags Details

Description Lubos Kocman 2010-08-04 12:16:57 UTC
Created attachment 436510 [details]
strace of qemu-kvm

Description:

I'm facing one issue with dual head on winxp guest, please let me know if it's
related to this or if I should open separate bug for this issue.

Here are steps that I made before it happened

1)  Clean install of WinXP into qemu-kvm
2) install rhev-tools into guest
3) reboot -> shutdown
4) sudo /usr/libexec/qemu-kvm -vga qxl -device qxl -m  512 -soundhw ac97 -spice
port=3002,disable-ticketing /dev/rootvg/winxp32_root
5) spicec -h localhost -p 3002
5) Right click on desktop -> Settings -> Extend display + set up both displays
to 1024x768


(Same crash occurs on each boot of winxp guest ,removing -device qxl does not make any change)

Actual results:

qemu-kvm crashes with "I/O Possible" message

See attached strace output (strace of qemu-kvm with the same params as in Ad. 4) and qemu-kvm output

Comment 1 Lubos Kocman 2010-08-04 12:17:22 UTC
Version of software is:

qemu-kvm-0.12.1.2-2.107.el6.x86_64

Comment 2 Lubos Kocman 2010-08-04 12:17:48 UTC
Created attachment 436511 [details]
qemu-kvm output

Comment 3 Amit Shah 2010-08-04 12:42:07 UTC
Please attach the crash log.

Try connecting gdb to qemu-kvm and getting a backtrace.

Comment 6 Gerd Hoffmann 2010-08-04 15:04:51 UTC
QEMU_AUDIO_DRV=pa (default) fails.

When using spice QEMU_AUDIO_DRV=spice should be used, otherwise forwarding audio to the spice client doesn't work.  libvirt will do that for you btw.

I *think* one of the pulseaudio threads receives SIGIO (need to double-check that though).  Doesn't looks spice-related at first glance.  Nevertheless it triggers only with spice enabled.

Comment 7 Lubos Kocman 2010-08-04 15:29:41 UTC
Yes removing -soundhw ac97 does help

Comment 8 Gerd Hoffmann 2010-08-06 08:09:37 UTC
http://patchwork.ozlabs.org/patch/61072/
Patch posted to rhvirt-patches.

Comment 12 Lubos Kocman 2010-08-10 07:46:48 UTC
Verified on qemu-kvm-0.12.1.2-2.109.el6. Works for me now.

Comment 13 Lubos Kocman 2010-08-11 10:56:08 UTC
*** Bug 614915 has been marked as a duplicate of this bug. ***

Comment 14 releng-rhel@redhat.com 2010-11-10 21:27:03 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.