Bug 62117 - Smp kernel sees only one of 4 slimmerlot cpu's with multiple pci cards
Summary: Smp kernel sees only one of 4 slimmerlot cpu's with multiple pci cards
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-27 17:19 UTC by Clay Cooper
Modified: 2007-04-18 16:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 19:12:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pirq output of configuration that incorrectly sees 1 cpu (4.21 KB, text/plain)
2002-03-27 17:22 UTC, Clay Cooper
no flags Details
mptable output of configuration that incorrectly sees 1 cpu (32.13 KB, text/plain)
2002-03-27 17:22 UTC, Clay Cooper
no flags Details
pirq output of configuration that correctly sees 8 logical cpu's (hyperthreading enabled) (4.17 KB, text/plain)
2002-03-27 17:24 UTC, Clay Cooper
no flags Details
mptable output of configuration that correctly sees 8 logical cpu's (hyperthreading enabled) (29.27 KB, text/plain)
2002-03-27 17:25 UTC, Clay Cooper
no flags Details
ksymoops output of oopsing configuration (4.02 KB, text/plain)
2002-03-27 17:26 UTC, Clay Cooper
no flags Details

Description Clay Cooper 2002-03-27 17:19:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
On a slimmerlot with hampton beta3 installed (2.4.18-0.4smp), w/ bios A02, 1GB
ram, 2GB swap, and LSI 22320 as boot device...

3 different configurations give 3 different results:

22320 in slot 2, Perc3QC in slot 3 (with PV210S attached), Perc3DCL in slot 4,
1000XT in slot 5, Dual Pro 100 in slot 6, Pro 100 in slot 7 -- smp kernel only
sees 1 of 4 cpu's

Remove nics from slots 6 and 7 and kernel oops during cpu detection

Then remove Perc3QC and DCL also (leaving 22320 and 1000XT) and 4 cpu's are
correctly detected.

Each of these three results are reproducible everytime.

Same results with hyperthreading (logical processors) enabled or disabled in
bios.  Of course, in the working configuration, 4 or 8 processors are seen
depending on the setting.

Attaching mptable and pirq output from the two configurations that boot, and
ksymoops output from oopsing configuration.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install hampton beta3 on a slimmerlot with listed configuration
2.Note oops or incorrect cpu detection depending on configuration
3.
	

Actual Results:  Incorrect cpu detection or oops

Expected Results:  Correct cpu detection

Additional info:

Comment 1 Clay Cooper 2002-03-27 17:22:12 UTC
Created attachment 50905 [details]
pirq output of configuration that incorrectly sees 1 cpu

Comment 2 Clay Cooper 2002-03-27 17:22:59 UTC
Created attachment 50907 [details]
mptable output of configuration that incorrectly sees 1 cpu

Comment 3 Clay Cooper 2002-03-27 17:24:18 UTC
Created attachment 50908 [details]
pirq output of configuration that correctly sees 8 logical cpu's (hyperthreading enabled)

Comment 4 Clay Cooper 2002-03-27 17:25:20 UTC
Created attachment 50910 [details]
mptable output of configuration that correctly sees 8 logical cpu's (hyperthreading enabled)

Comment 5 Clay Cooper 2002-03-27 17:26:13 UTC
Created attachment 50911 [details]
ksymoops output of oopsing configuration

Comment 6 Matt Domsch 2002-03-27 17:46:29 UTC
This is because the 2.4.18-0.4 kernel on beta3 does not include the MP 
Table "MAX_MP_BUSSES" overflow bug fix which kills Merlot/SlimMerlot.

The latest rawhide kernel 2.4.18-0.10 does have the fix.  Clay, please try this.

So, I think this is a duplicate of #60754, which claims to have been fixed for 
beta3, but clearly wasn't.


Comment 7 Clay Cooper 2002-03-27 19:11:57 UTC
Tried 2.4.18-0.10smp with all 6 pci cards in the machine and received expected
behaviour.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.