Bug 621179 - tps-make-lists from comparative workflow fails on ppc64
Summary: tps-make-lists from comparative workflow fails on ppc64
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
(Show other bugs)
Version: 0.5
Hardware: All Linux
high
high vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 593365
TreeView+ depends on / blocked
 
Reported: 2010-08-04 13:26 UTC by Karel Srot
Modified: 2010-08-10 12:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 12:25:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karel Srot 2010-08-04 13:26:11 UTC
Description of problem:

tps-make-lists from comparative workflow fails on ppc64 platform. 
I have executed comporative workflow in beaker and encounted the bug described in bug 580384. Please take a look at 
https://bugzilla.redhat.com/show_bug.cgi?id=580384#c10 
and comments that folows for additional info.

In beaker there is the same problem with tps-make-lists 2010:9745 4AS ppc/ppc64 as in RHTS. Moreover, after scheduling a job 
https://beaker.engineering.redhat.com/jobs/10449
I have found that /mnt/redhat was not mounted and therefore packages in brewroot were not accessible.

Comment 1 Bill Peck 2010-08-04 14:02:12 UTC
in regard to failing on the ppc64 architecture.  Can the tps setup/upgrade tests be modified to undefine ARCH when calling the tps commands?

ARCH="" tps-make-lists $ERRATUM

in regard to the failing to mount /mnt/redhat.  Can you point out in the logs where it failed to mount /mnt/redhat?  I can't find it myself.

Comment 2 Karel Srot 2010-08-05 08:53:10 UTC
> in regard to the failing to mount /mnt/redhat.  Can you point out in the logs
> where it failed to mount /mnt/redhat?  I can't find it myself.  

When I tried to execute tps-make-lists command manualy I got an error regarding packages not available in brewroot. That's how I have realized that /mnt/redhat is not mounted. I do not know why because I didn't unmount/reboot the server. Anyway, I tried to schedule the same test again and the problem did not appear, /mnt/redhat is mounted as it should. I think you can ignore it.

Comment 3 Bill Peck 2010-08-05 13:37:04 UTC
I noticed in your previous job that one of the tests local watchdog expired.  When this happens we reboot the machine before moving on to the next test.  This would clear any nfs mounts.

Comment 4 Marian Csontos 2010-08-09 07:56:02 UTC
Comment 2 and Comment 3 say it all: this is a problem with given test being killed by local-watchdog.

Karel, may be the duration is inadequate or there is a problem in itself.

Thanks Bill, for looking at this.

I have opened Bug 622392 for tracking comparative w/ reboot not working.

Comment 5 Karel Srot 2010-08-09 12:43:23 UTC
Reopening the bug. The main problem in this bug is with the tps-make-lists failing on ppc64 platform. The note about the missing mount point was just a remark. 

I will ask pmuller to update the workflow test. I tried to test in beaker-stage but for some reason the test has not been updated.

Comment 6 Marian Csontos 2010-08-09 12:56:27 UTC
It's in your hands now.
Is it still high priority?

Comment 7 Karel Srot 2010-08-09 15:15:52 UTC
Well, it is simple. We need working rcw for errata testing. 

After the update of the test the only problem is with downgrade test, probably not an issue.
https://beaker.engineering.redhat.com/jobs/11347

Comment 8 Bill Peck 2010-08-09 15:31:36 UTC
so is this all set then?  Can we close?

Thanks

Comment 9 Karel Srot 2010-08-10 06:55:23 UTC
> so is this all set then?  Can we close?

I think so. Thank you for help.


Note You need to log in before you can comment on or make changes to this bug.