Bug 621256 - selinux policy update for ccid with libusb1
Summary: selinux policy update for ccid with libusb1
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 15:33 UTC by Kalev Lember
Modified: 2010-08-04 18:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 18:28:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kalev Lember 2010-08-04 15:33:50 UTC
I just rebuilt ccid-1.4.0 against libusb1 (previously it used old libusb 0.1) and it looks like pcscd selinux policy also needs updating. pcscd loads ccid library at runtime, so the denials are about pcscd.

Please update selinux-policy in both rawhide and F-14.

type=1400 audit(1280934816.565:9): avc:  denied  { read } for  pid=13917 comm="pcscd" name="devices" dev=sysfs ino=2232 scontext=unconfined_u:system_r:pcscd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=dir
type=1400 audit(1280934816.565:10): avc:  denied  { read } for  pid=13917 comm="pcscd" name="usb1" dev=sysfs ino=7677 scontext=unconfined_u:system_r:pcscd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=lnk_file
type=1400 audit(1280934816.565:11): avc:  denied  { getattr } for  pid=13917 comm="pcscd" path="/sys/devices/pci0000:00/0000:00:1a.7/usb1/descriptors" dev=sysfs ino=7681 scontext=unconfined_u:system_r:pcscd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file
type=1400 audit(1280934816.565:12): avc:  denied  { read } for  pid=13917 comm="pcscd" name="busnum" dev=sysfs ino=7666 scontext=unconfined_u:system_r:pcscd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file
type=1400 audit(1280934816.565:13): avc:  denied  { open } for  pid=13917 comm="pcscd" name="busnum" dev=sysfs ino=7666 scontext=unconfined_u:system_r:pcscd_t:s0 tcontext=system_u:object_r:sysfs_t:s0 tclass=file

Comment 1 Daniel Walsh 2010-08-04 18:28:31 UTC
Fixed in selinux-policy-3.8.8-10.fc14


Note You need to log in before you can comment on or make changes to this bug.