Bug 621315 - update section about @conflicts
update section about @conflicts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Ruediger Landmann
ecs-bugs
: Documentation
: 622919 (view as bug list)
Depends On:
Blocks: 253443
  Show dependency treegraph
 
Reported: 2010-08-04 14:36 EDT by Dennis Gregorovic
Modified: 2010-11-11 10:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:35:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2010-08-04 14:36:29 EDT
In 32.5. Package Selection:

The following should be changed from

"""
You can use a kickstart file to install every available package by specifying @Everything or simply * in the %packages section. Red Hat does not support this type of installation.
Moreover, using a kickstart file in this way will introduce package and file conflicts onto the installed system. Packages known to cause such problems are assigned to the @Conflicts group. If you specify @Everything in a kickstart file, be sure to exclude @Conflicts or the installation will fail:

@Everything
-@Conflicts

Note that Red Hat does not support the use of @Everything in a kickstart file, even if you exclude @Conflicts. 
"""

to

"""
You can use a kickstart file to install every available package by specifying @Everything or simply * in the %packages section. Red Hat does not support this type of installation.
Moreover, using a kickstart file in this way will introduce package and file conflicts onto the installed system. Packages known to cause such problems are assigned to the @Conflicts (VARIANT) group, where VARIANT is one of Server, Client, etc. If you specify @Everything in a kickstart file, be sure to exclude @Conflicts (VARIANT) or the installation will fail:

@Everything
-@Conflicts (Server)

Note that Red Hat does not support the use of @Everything in a kickstart file, even if you exclude @Conflicts (VARIANT). 
"""
Comment 1 Ruediger Landmann 2010-08-08 16:03:29 EDT
Thanks Dennis -- fixed in build 0-85
Comment 2 Andrew Ross 2010-08-08 18:50:26 EDT
Verified: Red_Hat_Enterprise_Linux-Installation_Guide-6-web-en-US-0-85.el5

Text included in Warning at start of page.
Comment 3 Ruediger Landmann 2010-08-15 19:56:17 EDT
*** Bug 622919 has been marked as a duplicate of this bug. ***
Comment 4 releng-rhel@redhat.com 2010-11-11 10:35:08 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.