Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 621321 - build of pdftk doesn't find libgcj
build of pdftk doesn't find libgcj
Status: CLOSED DUPLICATE of bug 619156
Product: Fedora
Classification: Fedora
Component: pdftk (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 14:49 EDT by Jochen Schmitt
Modified: 2010-08-11 12:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 09:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2010-08-04 14:49:36 EDT
Description of problem:

When I try to build pdftk to rawhide, I will get the following
error:

/usr/include/bits/string3.h:154:71: warning: call to char* __builtin___strncat_chk(char*, const char*, long unsigned int, long unsigned int) might overflow destination buffer
g++ pdftk.o attachments.o report.o /usr/lib64/gcj/itext/itext-2.1.7.jar.so  -I../java_libs -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -fdollars-in-identifiers -g -fpic -DPDFTK_VER=\"1.41\" -lgcj -o pdftk
/usr/bin/ld: cannot find -lgcj
report.o: In function `ReplaceXmp(com::lowagie::text::pdf::PdfReader*, std::basic_string<char, std::char_traits<char>, std::allocator<char> >)':
/builddir/build/BUILD/pdftk-1.41/pdftk/report.cc:1292: warning: the use of `tmpnam' is dangerous, better use `mkstemp'
collect2: ld returned 1 exit status
make: *** [pdftk] Error 1
RPM build errors:

Refer to koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2379863


Version-Release number of selected component (if applicable):

gcc-4.5.0-3.fc14

How reproducible:

Try a scratch build of pdftk for rawnide.

  
Actual results:

The build fails with an error message.

Expected results:

the build should run succesfully.

Additional info:

I assume the reason for this bug is the absent of the libgcj.so file in the libgcj-devel package. this may caused by a switch defined in the SPEC file.
Comment 1 Jakub Jelinek 2010-08-11 02:53:45 EDT
You need gcc-java installed if you want to compile or link java stuff.
Comment 2 Jakub Jelinek 2010-08-11 09:48:33 EDT

*** This bug has been marked as a duplicate of bug 619156 ***

Note You need to log in before you can comment on or make changes to this bug.