Bug 621439 - xapian-core includes SSE instructions
xapian-core includes SSE instructions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xapian-core (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 00:06 EDT by Daniel Drake
Modified: 2010-08-05 13:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: xapian-core-1.2.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 02:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Drake 2010-08-05 00:06:28 EDT
xapian-core-1.2.2 includes SSE + SSE2 instructions by default, if being built on x86 by gcc. (very questionable, IMO)

Some processors supported by Fedora do not support SSE instructions, such as the Geode LX in the OLPC XO-1.

Any program that uses libxapian on this system will crash with SIGILL. Makes sugar unusable.


Solution: change spec file to add --disable-sse configure argument, bringing this package in line with the rest of the world.

%configure --disable-static --disable-sse
Comment 1 Peter Robinson 2010-08-05 02:33:10 EDT
built for rawhide and F-14 which are the only releases that ship 1.2
Comment 2 Adel Gadllah 2010-08-05 13:41:25 EDT
(In reply to comment #1)
> built for rawhide and F-14 which are the only releases that ship 1.2    

This is a wrong solution, there is *no* reason not to enable it on x86_64 as it is part of the x86_64 abi .. IOW SSE2/SSE is *always* present on x86_64.

So I have reenabled it for x86_64, as it makes no sense to disable it there.
Comment 3 Daniel Drake 2010-08-05 13:45:28 EDT
I don't think thats correct. As badly as it is named, --disable-sse should also be used on x86_64.

SSE and SSE2 *will* be used in this case, due to the global -march= settings used for all packages in Fedora.

Note You need to log in before you can comment on or make changes to this bug.