Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621486 - Fails to boot graphically, requires LUKS password in text mode
Fails to boot graphically, requires LUKS password in text mode
Status: CLOSED DUPLICATE of bug 615912
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 04:59 EDT by Tim Waugh
Modified: 2010-08-05 06:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 06:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2010-08-05 04:59:20 EDT
Description of problem:
Since upgrading on Aug 4th I am seeing this message on boot, instead of a nice graphical password dialog on my LUKS-encrypted system:

could not read byte from child: Success

and it then proceeds to ask me for the LUKS password for *each* partition.

Last known good: kernel-2.6.32-54.el6, installed July 30th.

Version-Release number of selected component (if applicable):

$ rpm -qa --last | grep -E 'plymouth|dracut|kernel'
kernel-headers-2.6.32-57.el6                  Wed 04 Aug 2010 17:41:57 BST
kernel-devel-2.6.32-57.el6                    Wed 04 Aug 2010 17:41:51 BST
plymouth-system-theme-0.8.3-15.el6            Wed 04 Aug 2010 17:41:18 BST
kernel-2.6.32-57.el6                          Wed 04 Aug 2010 17:41:14 BST
kernel-firmware-2.6.32-57.el6                 Wed 04 Aug 2010 17:39:16 BST
plymouth-theme-rings-0.8.3-15.el6             Wed 04 Aug 2010 17:39:12 BST
plymouth-utils-0.8.3-15.el6                   Wed 04 Aug 2010 17:39:02 BST
plymouth-gdm-hooks-0.8.3-15.el6               Wed 04 Aug 2010 17:39:02 BST
plymouth-scripts-0.8.3-15.el6                 Wed 04 Aug 2010 17:39:01 BST
plymouth-0.8.3-15.el6                         Wed 04 Aug 2010 17:39:01 BST
plymouth-plugin-two-step-0.8.3-15.el6         Wed 04 Aug 2010 17:38:46 BST
plymouth-plugin-label-0.8.3-15.el6            Wed 04 Aug 2010 17:38:45 BST
plymouth-graphics-libs-0.8.3-15.el6           Wed 04 Aug 2010 17:38:40 BST
plymouth-core-libs-0.8.3-15.el6               Wed 04 Aug 2010 17:38:37 BST
kernel-2.6.32-54.el6                          Fri 30 Jul 2010 11:50:10 BST
dracut-kernel-004-29.el6                      Fri 30 Jul 2010 11:47:51 BST
dracut-004-29.el6                             Fri 30 Jul 2010 11:47:50 BST
kernel-devel-2.6.32-54.el6                    Fri 30 Jul 2010 11:23:32 BST
abrt-addon-kerneloops-1.1.12-2.el6            Fri 30 Jul 2010 11:22:18 BST
kernel-devel-2.6.32-52.el6                    Fri 23 Jul 2010 11:03:14 BST
kernel-2.6.32-52.el6                          Fri 23 Jul 2010 10:49:22 BST

How reproducible:
100%

Steps to Reproduce:
1.Just try to boot.
  
Actual results:
Error message, text mode instead of graphics mode, password asked for repeatedly instead of just once.

Expected results:
Graphical password dialog requires password just once, graphical login animation, etc.
Comment 1 RHEL Product and Program Management 2010-08-05 05:07:49 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 2 Tim Waugh 2010-08-05 06:10:30 EDT
plymouth-0.8.3-16.el6.x86_64 fixes it.

*** This bug has been marked as a duplicate of bug 615912 ***

Note You need to log in before you can comment on or make changes to this bug.