Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 621490 - Can't specify custom value for shrinking filesystem
Can't specify custom value for shrinking filesystem
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks: 582286 647893
  Show dependency treegraph
 
Reported: 2010-08-05 05:15 EDT by Marian Ganisin
Modified: 2011-05-19 08:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.88-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:31:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda logs generated by SIGUSR2 signal (196.00 KB, text/plain)
2010-08-05 09:19 EDT, Marian Ganisin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0530 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-05-18 13:44:52 EDT

  None (edit)
Description Marian Ganisin 2010-08-05 05:15:57 EDT
Description of problem:
I prepared system with ext4 partition created on whole disk.
During installation I tried to shrink this device (due to verification of Bug 602442), however I wasn't able to change non-zero default value (it was 353 MB in my case). If I set different size, it was ignored and default value was used instead.

Version-Release number of selected component (if applicable):
RHEL6.0-20100730.5
anaconda-13.21.66-1.el6.i686

Additional info:
Seems to be blocker to me, however I can't evaluate real impact to the customers needs and expectations.
Comment 1 Chris Lumens 2010-08-05 08:16:25 EDT
Please attach logs when reporting bugs.
Comment 2 Marian Ganisin 2010-08-05 09:19:52 EDT
Created attachment 436846 [details]
anaconda logs generated by SIGUSR2 signal

Sorry! logs attached.

However I found the issue. I used 'Alt+S' keyboard shortcut for 'Shrink' button to submit 'Volume to Shrink' dialog, user defined value is ignored in this case.
Comment 3 Chris Lumens 2010-08-05 09:30:33 EDT
We'll look into it, though I do not believe this is blocker material.  It does not prevent installation.
Comment 5 Brian Lane 2010-11-19 12:15:00 EST
Did you try to set the value higher or lower than 353? It will not let you shrink it any lower than the minimum size of the partition.
Comment 6 Marian Ganisin 2010-11-23 04:31:13 EST
(In reply to comment #5)
> Did you try to set the value higher or lower than 353?

Yes, I did.
Comment 7 Marian Ganisin 2010-11-23 04:32:10 EST
(In reply to comment #6)
> (In reply to comment #5)
> > Did you try to set the value higher or lower than 353?
> 
> Yes, I did.
... set the value higher than 353. :)
Comment 8 Brian Lane 2011-01-11 14:55:00 EST
Ends up you need to call .update() on the spinbuttons to make sure they have the latest value.
Comment 10 Alexander Todorov 2011-04-01 11:10:20 EDT
In Snap #2 changing the size of the partition and then using Alt+S works as expected.
Comment 11 errata-xmlrpc 2011-05-19 08:31:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html

Note You need to log in before you can comment on or make changes to this bug.