Bug 621535 - build failed on openSUSE-11.2
build failed on openSUSE-11.2
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 08:15 EDT by Andrey Ponomarenko
Modified: 2010-08-19 09:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
openSUSE-11.2, x86
Last Closed: 2010-08-19 05:41:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make V=1 log (301.69 KB, text/plain)
2010-08-19 02:58 EDT, Andrey Ponomarenko
no flags Details
./configure >log.txt 2>&1 (37.60 KB, text/plain)
2010-08-19 05:12 EDT, Andrey Ponomarenko
no flags Details

  None (edit)
Description Andrey Ponomarenko 2010-08-05 08:15:00 EDT
Description of problem:
build failed on openSUSE-11.2

Version-Release number of selected component (if applicable): 0.8.3

How reproducible: always

Steps to Reproduce:
1. ./configure
2. make
3.
  
Build errors:
...
  CCLD   libvirt_driver_esx.la
  CC     libvirt_driver_nwfilter_la-nwfilter_driver.lo
  CC     libvirt_driver_nwfilter_la-nwfilter_gentech_driver.lo
  CC     libvirt_driver_nwfilter_la-nwfilter_ebiptables_driver.lo
  CC     libvirt_driver_nwfilter_la-nwfilter_learnipaddr.lo
  CCLD   libvirt_driver_nwfilter.la
libtool: link: require no space between `-L' and `/usr/lib'
make[3]: *** [libvirt_driver_nwfilter.la] Error 1
make[3]: Leaving directory `/home/andrey/upstream-tracker/repository/libvirt/install/libvirt-0.8.3/src'
Comment 1 Daniel Berrange 2010-08-17 09:10:40 EDT
I'm not able to reproduce a problem on any Fedora box, so it must be specific to the build options used on OpenSuse. Can you capture the logs with  'make V=1' so we can see the actual compiler args used.
Comment 2 Andrey Ponomarenko 2010-08-19 02:58:40 EDT
Created attachment 439596 [details]
make V=1 log

Output of the command `make V=1`
The last line is the following:

/bin/sh ../libtool  --tag=CC   --mode=link gcc -I /usr/include -I../src/conf  -g -O2    -o libvirt_driver_nwfilter.la  libvirt_driver_nwfilter_la-nwfilter_driver.lo libvirt_driver_nwfilter_la-nwfilter_gentech_driver.lo libvirt_driver_nwfilter_la-nwfilter_ebiptables_driver.lo libvirt_driver_nwfilter_la-nwfilter_learnipaddr.lo -L /usr/lib -lpcap   -ldl 
libtool: link: require no space between `-L' and `/usr/lib'

This bug was introduced in the 0.8.3, because of the 0.8.2 was successfully installed on my system.
Comment 3 Daniel Berrange 2010-08-19 04:08:01 EDT
Can you also provide the full output from 'configure' including details of any args passed to it.
Comment 4 Andrey Ponomarenko 2010-08-19 05:12:09 EDT
Created attachment 439626 [details]
./configure >log.txt 2>&1

Added output of configure
Comment 5 Andrey Ponomarenko 2010-08-19 05:37:53 EDT
`pcap-config --libs` command always returns "-L /usr/lib"
I've checked 1.0.0 and 1.1.1 versions.

I have recently installed a pcap-1.0.0 from the SUSE repository and previous versions of libvirt were installed without pcap:

checking libpcap pcap-config >= 1.0.0 ... no

But now the configure detected a pcap:

checking libpcap pcap-config >= 1.0.0 ... yes
Comment 6 Daniel Berrange 2010-08-19 05:41:46 EDT
Ok, this is a bug in "pcap-config", rather than libvirt. It should not be adding this whitespace. Indeed it shouldn't add  -L/usr/lib at all since /usr/lib is in the default search path. As is /usr/include.
Comment 7 Andrey Ponomarenko 2010-08-19 09:46:54 EDT
Thank you, I've reported it to pcap.

Note You need to log in before you can comment on or make changes to this bug.