Bug 621560 - io scheduler cfq registered hangs [NEEDINFO]
io scheduler cfq registered hangs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 09:32 EDT by acrosson
Modified: 2014-06-03 08:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:49:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vgoyal: needinfo? (acrosson)
pm-rhel: needinfo? (acrosson)


Attachments (Terms of Use)

  None (edit)
Description acrosson 2010-08-05 09:32:33 EDT
Description of problem:
RHEL 5.5 does not install due to a io scheduler problem in which machine locks up and does not install. 

Version-Release number of selected component (if applicable):


How reproducible:
Install RHEL5.5 i386/x86_64 with kernel 2.6.18-194.el5 

Steps to Reproduce:
1. Install RHEL5.5 i386/x86_64 with kernel 2.6.18-194.el5
2.
3.
  
Actual results:PID hash table entries: 4096 (order: 12, 32768 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
Checking aper..
ACPI: DMAR not present
Memory: 1017740k/1047552k available (2577k kernel code, 29328k reserved, 1305k data, 212k init)
Calibrating delay loop (skipped), value calculated using timer frequency.. 4000.26 BogoMIPS (lpj=2000130)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entri: 256
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 4096K
using mwait in idle threads.
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
CPU0: Thermal monitoring enabled (TM2)
SMP alternatives: switching to UP code
ACPI: Core revision 20060707
Using local APIC timer interrupts.
Detected 20.834 MHz APIC timer.
SMP alternatives: switching to SMP code
Booting processor 1/2 APIC 0x1
Initializing CPU#1
Calibrating delay using timer specific routine.. 3999.56 BogoMIPS (lpj=1999781)
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 4096K
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
CPU1: Thermal monitoring enabled (TM2)
Intel(R) Xeon(R) CPU            5130  @ 2.00GHz stepping 06
Brought up 2 CPUs
testing NMI watchdog ... OK.
time.c: Using 3.579545 MHz WALL PM GTOD PIT/TSC timer.
time.c: Detected 2000.130 MHz processor.
migration_cost=25
checking if image is initramfs... it is
Freeing initrd memory: 7868k freed
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using MMCONFIG at e0000000
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: No dock devices found.
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Transparent bridge - 0000:00:1e.0
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 11 14 15) *12
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 11 14 15) *12
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 *4 5 6 7 10 11 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *10 11 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 *10 11 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 4 *5 6 7 10 11 14 5)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 *6 7 10 11 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 4 5 6 *7 10 11 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: IRQ 11 override to level, high
pnp: PnP ACPI: found 8 devices
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
ACPI: DMAR not present
PCI-GART: No AMD northbridge found.
PCI: mem resource #9:100000@de100000 for 0000:02:02.0 was not allocated.
PCI: mem resource #9:100000@de100000 for 0000:04:09.0 was not allocated.
PCI: Bridge: 0000:04:01.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:06:00.0
  IO window: disabled.
  MEM window: de200000-de2fffff
  PREFETCH window 0x00000000de000000-0x00000000de0fffff
PCI: Bridge: 0000:06:00.2
  IO window: 2000-2fff
  MEM window: de300000-de3fffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:04:08.0
  IO window: 2000-2fff
  MEM window: de200000-de3fffff
  PREFETCH window 0x00000000de000000-0x00000000de0fffff
PCI: Bridge: 0000:04:09.0
  IO window: 3000-3fff
  MEM window: de400000-de4fffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:03:00.0
  IO window: 2000-3fff
  MEM window: de200000-de4fffff
  PREFETCH window 0x000000de000000-0x00000000de0fffff
PCI: Bridge: 0000:02:00.0
  IO window: 2000-3fff
  MEM window: de100000-de4fffff
  PREFETCH window 0x00000000de000000-0x00000000de0fffff
PCI: Bridge: 0000:02:02.0
  IO window: 4000-4fff
  MEM window: de500000-de5fffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:01:00.0
  IO window: 2000-4fff
  MEM window: de100000-de5fffff
  PREFETCH window 0x00000000de000000-0x00000000de0fffff
PCI: Bridge: 0000:01:00.3
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:02.0
  IO window: 2000-4fff
  MEM window: de100000-de6fffff
  PREFETCwindow 0x00000000de000000-0x00000000de0fffff
PCI: Bridge: 0000:00:03.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:04.0
  IO window: 5000-5fff
  MEM window: de700000-de7fffff
  PREFETCH window 0x0000000050000000-0x00000000500fffff
PCI: Bridge: 0000:00:05.0
  IO window: 6000-6fff
  MEM window: df100000-df1fffff
  PREFETCH window 0x0000000050100000-0x00000000501fffff
PCI: Bridge: 0000:00:06.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1c.0
  IO window: disabled.
  MEM window: de800000-df0fffff
  PREFETCH window 0x00000000dd000000-0x00000000ddffffff
PCI: Bridge: 0000:00:1e.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
GSI 16 sharing vector 0xA9 and IRQ 16
ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI evel, low) -> IRQ 169
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 16 (level, low) -> IRQ 169
GSI 17 sharing vector 0xB1 and IRQ 17
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 17 (level, lw) -> IRQ 177
ACPI: PCI Interrupt 0000:04:08.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:04:09.0[A] -> GSI 17 (level, low) -> IRQ 177
GSI 18 sharing vector 0xB9 and IRQ 18
ACPI: PCI Interrupt 0000:02:02.0[A] -> GSI 18 (level, low) -> IRQ 
ACPI: PCI Interrupt 0000:00:03.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:00:04.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:00:05.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:00:06.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 17 (level, low) -> IRQ 177
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 6, 62144 bytes)
TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
Simple Boot Flag at 0x46set to 0x1
audit: initializing netlink socket (disabled)
type=2000 audit(1278611662.610:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Initializing Cryptographic API
alg: No test for crc32c (crc32c-generic)
io scheduler nooistered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)




Expected results:

To be able to install RHEL5.5 with out machine hanging on io scheduler.

Additional info:

I am able to have machine install if I append acpi=off to kernel options.
look at comment 2 for more details.
Comment 2 Vivek Goyal 2010-08-05 10:28:39 EDT
Because you are able to boot with acpi=off, it is unlikely that it is CFQ issue. 

Can you try elevator=deadline option on kernel options and see if install is
successful or not (no acpi=off specified). If it is not successful, then it will more of less confirm that it is not CFQ issue but something else.
Comment 4 RHEL Product and Program Management 2014-03-07 07:49:04 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-03 08:49:32 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.