Bug 621647 - Exception occurs on install when multipath is enabled
Exception occurs on install when multipath is enabled
Status: CLOSED DUPLICATE of bug 575749
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 13:47 EDT by cartmancakes
Modified: 2010-08-18 09:20 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 09:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 2 (199.01 KB, image/jpeg)
2010-08-05 13:48 EDT, cartmancakes
no flags Details
screenshot 3 (208.96 KB, image/jpeg)
2010-08-05 13:49 EDT, cartmancakes
no flags Details
screenshot 1 (136.29 KB, image/jpeg)
2010-08-05 13:49 EDT, cartmancakes
no flags Details
Anaconda Log (6.68 KB, application/octet-stream)
2010-08-16 20:51 EDT, cartmancakes
no flags Details

  None (edit)
Description cartmancakes 2010-08-05 13:47:52 EDT
Description of problem:
When installing RHEL6 beta 2, when choosing a disk to install the OS on, if there is more than one path to any disks, an exception will occur.  This seems to be a multipath / anaconda error.

Version-Release number of selected component (if applicable):
inbox for RHEL6 beta 2

How reproducible:
constant

Steps to Reproduce:
1. configuration should include more than one path to a SAN array
2. Install OS, using any disk (multipath or not)
3. Use all defaults
  
Actual results:
See screenshots.  
"Could not commit to to disk /dev/mapper/mpathn"

Expected results:
Should have begun installation

Additional info:
This is an HP BL490c G6, connected to an EVA6400 multipathed through a Cisco and Brocade fabric.  This was done using the Emulex NC553i, LPe1105, and LPe1205.
Comment 1 cartmancakes 2010-08-05 13:48:59 EDT
Created attachment 436922 [details]
screenshot 2
Comment 2 cartmancakes 2010-08-05 13:49:25 EDT
Created attachment 436923 [details]
screenshot 3
Comment 3 cartmancakes 2010-08-05 13:49:50 EDT
Created attachment 436924 [details]
screenshot 1
Comment 5 RHEL Product and Program Management 2010-08-05 14:07:53 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Ben Marzinski 2010-08-05 16:30:52 EDT
The only information that looks helpful to be in in screenshot 2.  It appears that device-mapper in unable to creat a linear device.  This could be a kpartx partition on the multipath device.  If this is the case, this bug might be
another instance of 612173. However, without more of anaconda's logs, it's pretty hard to tell.
Comment 7 cartmancakes 2010-08-05 16:34:52 EDT
(In reply to comment #6)
> The only information that looks helpful to be in in screenshot 2.  It appears
> that device-mapper in unable to creat a linear device.  This could be a kpartx
> partition on the multipath device.  If this is the case, this bug might be
> another instance of 612173. However, without more of anaconda's logs, it's
> pretty hard to tell.    

I'll  see about collecting as many logs as possible.  Thanks!
Comment 9 cartmancakes 2010-08-16 20:51:05 EDT
Created attachment 439037 [details]
Anaconda Log
Comment 10 cartmancakes 2010-08-16 20:53:18 EDT
I have all of the logs in /tmp, so let me know what else you need...

I've recently tried snapshot 10 with the same config, and I'm getting a different error, sooner than this one.  So I cannot verify if it works in snapshot 10 or not.
Comment 12 David Cantrell 2010-08-18 09:20:20 EDT
The first issue you were seeing about could not commit to disk has been fixed in more recent snapshots.  The issue you are seeing in comment #10 has been fixed in anaconda-13.21.69-1.  Duping this bug against the latter issue since that's the most recent snapshot you are trying.

*** This bug has been marked as a duplicate of bug 575749 ***

Note You need to log in before you can comment on or make changes to this bug.