Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 621649 - Accessibility strings in sm-gui have been clobbered
Accessibility strings in sm-gui have been clobbered
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
All Linux
high Severity high
: rc
: ---
Assigned To: Bryan Kearney
wes hayutin
:
Depends On:
Blocks: 568421
  Show dependency treegraph
 
Reported: 2010-08-05 13:55 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
commit 44bde4f95ac64248d86d3e96823122c1ee4d1103
Last Closed: 2011-01-25 10:55:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2010-08-05 13:55:34 EDT
Description of problem:
The automation for subscription-manager-gui is breaking, due to more descriptive accessibility strings that have somehow reverted to more generic names.  Need to revert again back to the descriptive names.

I'll list the ones I know of now and add more if/when I find them.

1) After clicking "Add" on the main SM panel, the dialog that comes up is titled "Provide a Subscription Certificate".  The accessibility Name field used to be same as the title.  Now it is "dialog1_import".  

2) The "Import Certificate" button on the same panel - used to have accessibility name of "Import Certificate", now it's "import_cert_button4". 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adrian Likins 2010-08-05 15:06:31 EDT
Added back those strings. I think thats all thats missing, but it's a little hard to tell (file got renamed and moved, so git history is a bit weird). 

Should be in head as of now.
Comment 2 wes hayutin 2010-08-10 09:55:38 EDT
Jeff, can you check this please.
Thanks
Comment 3 Jeff Weiss 2010-08-10 10:05:00 EDT
Not fixed, the attributes are still the same in commit 4a5305968e771b18bc0db804d323ce1f83c10176
Comment 5 Bryan Kearney 2011-01-25 10:45:30 EST
Is this still an issue?
Comment 6 Jeff Weiss 2011-01-25 10:55:21 EST
Fixed.

Note You need to log in before you can comment on or make changes to this bug.