Bug 621688 - Broken update path
Broken update path
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 15:58 EDT by Jochen Schmitt
Modified: 2010-08-09 06:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 06:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2010-08-05 15:58:08 EDT
Description of problem:

When I try to upgrade from F-13 to rawhide, I will get the following
error messages:

Prüffehler bei Verarbeitung:
  file /usr/share/man/de/man1/zsoelim.1.gz from install of man-db-2.5.7-2.fc14.x86_64 conflicts with file from package man-pages-de-0.5-3.fc12.noarch
  file /usr/share/man/de/man1/manpath.1.gz from install of man-db-2.5.7-2.fc14.x86_64 conflicts with file from package man-pages-de-0.5-3.fc12.noarch
  file /usr/share/man/de/man5/manpath.5.gz from install of man-db-2.5.7-2.fc14.x86_64 conflicts with file from package man-pages-de-0.5-3.fc12.noarch
  file /usr/share/man/de/man8/catman.8.gz from install of man-db-2.5.7-2.fc14.x86_64 conflicts with file from package man-pages-de-0.5-3.fc12.noarch
  file /usr/share/man/de/man8/mandb.8.gz from install of man-db-2.5.7-2.fc14.x86_64 conflicts with file from package man-pages-de-0.5-3.fc12.noarch



Version-Release number of selected component (if applicable):

2.5.7-2


How reproducible:

See above.

Steps to Reproduce:
1. Start Fedora 13
2. yum install fedora-release-rawhide
3. yum --enablerepo rawhide update
  
Actual results:

Upgrade to rawhide fails.

Expected results:

clean upgrade to rawhide without any failure


Additional info:

The reason of this bug seem to be a movement of files between the packages
man-pages-de and man-db without the proper definition of Obsoletes: and Provides: statements.
Comment 1 Ivana Varekova 2010-08-09 06:21:32 EDT
Thanks. Fixed in 2.5.7-3.

Note You need to log in before you can comment on or make changes to this bug.