Bug 62175 - kdebase-3.0.0-0.cvs20020321.1 has two copies of many config files!!!
Summary: kdebase-3.0.0-0.cvs20020321.1 has two copies of many config files!!!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-28 05:18 UTC by Aleksey Nogin
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 21:27:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2002-03-28 05:18:05 UTC
The kdebase package from Skipjack updates (as pulled by up2date) is doing
something rather strange with configs:

rpm -qlv kdebase-3.0.0-0.cvs20020321.1 | grep kdmrc
-rw-r--r--    1 root    root            17071 Мар 21 10:35 /etc/X11/xdm/kdmrc
-rw-r--r--    1 root    root            17072 Мар 20 08:58 /etc/kde/kdm/kdmrc
lrwxrwxrwx    1 root    root               29 Мар 21 10:35
/usr/share/config/kdm/kdmrc -> ../../../../etc/X11/xdm/kdmrc

rpm -qlv kdebase-3.0.0-0.cvs20020321.1 | grep Xacc
-rw-r--r--    1 root    root             1926 Мар 14 08:51 /etc/kde/kdm/Xaccess
-rw-r--r--    1 root    root             1926 Мар 21 10:34
/usr/share/config/kdm/Xaccess

Why does it have 2 *different* copies of kdmrc *and* a symlink???

Comment 1 Bernhard Rosenkraenzer 2002-04-02 11:07:47 UTC
This is fixed in the current version.

Comment 2 Bernhard Rosenkraenzer 2002-04-02 11:09:05 UTC
(The symlinks are needed because of Bug #61413; the real fix would be to 
replace /usr/share/config/kdm with a symlink to /etc/X11/xdm).


Note You need to log in before you can comment on or make changes to this bug.