Bug 62181 - pnmflip segfaulting when using the -r90 -180 -r270 options
pnmflip segfaulting when using the -r90 -180 -r270 options
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: netpbm (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
: 62204 (view as bug list)
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-28 02:18 EST by Jef Spaleta
Modified: 2015-03-04 20:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 11:10:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2002-03-28 02:18:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
the pnmflip command is not behaving properly when using the rotate switches -r90
-r180 -r270, the -lr -tb switchs seems to work fine

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. pick your favorite jpg image
2. jpegtopnm whatever.jpg |pnmflip -r90 > whatever.pnm
3. the pnmflip process segfaults
	

Actual Results:  pnmflip errors out with a segfault

Expected Results:  pnmflip should have created a resultant pnm file rotated
according to the -r switch used.  this use to work. I have a program called
Gallery installed that makes use of pnmflip for image manipulations via the web.
 Old versions of the netpbm-prog package worked just fine.

Additional info:

No useful error messages just a segfualt statement
Comment 1 Phil Knirsch 2002-03-28 11:44:12 EST
*** Bug 62204 has been marked as a duplicate of this bug. ***
Comment 2 Bill Crawford 2002-03-28 22:45:42 EST
I saw this problem ages ago, when playing around with vidwhacker.  Rebuilding
the package from the source RPM fixed it (with gcc 3 installed) and does so
now.  I think this is a miscompilation problem with gcc 2.96.
Comment 3 Phil Knirsch 2002-04-09 10:36:10 EDT
OK, this is sort of a compiler optimizer bug. I've fixed it now in the source
and even optimized the whole thing by doing so. :-)

Will suggest this fix to the maintainer of the netpbm package upstream.

Read ya, Phil
Comment 4 Bill Crawford 2002-04-09 16:53:09 EDT
The source was valid though, if a little ugly :o)
Should I go log this against gcc or has that been done internally?


Note You need to log in before you can comment on or make changes to this bug.