Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 621915 - TypeError: argument 1 must be Entity, not None
TypeError: argument 1 must be Entity, not None
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:740ef48b3b2e0e4a2...
:
: 627202 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 09:43 EDT by AdiRusF
Modified: 2010-08-25 09:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 09:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (299.99 KB, text/plain)
2010-08-06 09:43 EDT, AdiRusF
no flags Details
Attached traceback automatically from anaconda. (307.42 KB, text/plain)
2010-08-09 11:49 EDT, Lawrence Graves
no flags Details

  None (edit)
Description AdiRusF 2010-08-06 09:43:32 EDT
The following was filed automatically by anaconda:
anaconda 14.15 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/users.py", line 260, in setUserPassword
    self.admin.setpassUser(user, cryptPassword(password, algo=algo), True)
  File "/usr/lib/python2.7/site-packages/pyanaconda/users.py", line 270, in setRootPassword
    self.rootPassword["lock"], algo)
  File "/usr/lib/python2.7/site-packages/pyanaconda/users.py", line 277, in write
    self.setRootPassword(algo=self.getPassAlgo())
  File "/usr/lib/python2.7/site-packages/pyanaconda/__init__.py", line 317, in write
    self.users.write(self.rootPath)
  File "/usr/lib/python2.7/site-packages/pyanaconda/backend.py", line 300, in writeConfiguration
    anaconda.write()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/text.py", line 510, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 887, in <module>
    anaconda.intf.run(anaconda)
TypeError: argument 1 must be Entity, not None
Comment 1 AdiRusF 2010-08-06 09:43:43 EDT
Created attachment 437149 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-08-06 09:50:07 EDT
There are a tremendous number of errors in your log file indicating that basically no packages got installed.  Of course I can't tell what the underlying problem is, but it's certainly not a problem with anaconda.
Comment 3 Lawrence Graves 2010-08-09 11:49:59 EDT
Created attachment 437630 [details]
Attached traceback automatically from anaconda.
Comment 4 Chris Lumens 2010-08-25 09:10:02 EDT
*** Bug 627202 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.