Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 621967 - php-channel-symfony should depend on php-xml
php-channel-symfony should depend on php-xml
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: php-channel-symfony (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Christof Damian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 12:24 EDT by Christopher Beland
Modified: 2010-08-06 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 12:56:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2010-08-06 12:24:24 EDT
Running "pear install symfony/symfony" results in the following error:

>>
symfony/symfony requires PHP extension "dom"
No valid packages found
install failed
<<

"yum install php-xml" cured this problem; php-channel-symfony should probably have a dependency on it.

Version: php-channel-symfony-1.3-1.fc12.noarch
Comment 1 Christof Damian 2010-08-06 12:56:28 EDT
(In reply to comment #0)
> Running "pear install symfony/symfony" results in the following error:
[...]
> 
> "yum install php-xml" cured this problem; php-channel-symfony should probably
> have a dependency on it.
> 
> Version: php-channel-symfony-1.3-1.fc12.noarch    

The problem is not that php-channel-symfony needs php-xml, but symfony does. If the package for symfony ( php-symfony-symfony https://bugzilla.redhat.com/show_bug.cgi?id=517191 ) ever passes the review it will have the dependency. 

If you install symfony directly with pear you have to deal with the dependencies yourself.

Note You need to log in before you can comment on or make changes to this bug.