Bug 62200 - RFE: Add option to %config(replace only if updating from >= 2.0)
RFE: Add option to %config(replace only if updating from >= 2.0)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 06:57 EST by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 06:58:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2002-03-28 06:57:59 EST
Description of Problem: 
If a config file format has changed between version 1.0 and 2.0, but not 
between 2.0 and 2.1, you usually want to replace the config file for anyone 
updating from 1.0, but leave the old config file intact for someone updating 
from 2.0. 
 
The current %config vs. %config(noreplace) doesn't allow to make a difference 
between these cases. 
 
Version-Release number of selected component (if applicable): 
4.0.4-7x.5
Comment 1 Jeff Johnson 2002-03-28 09:15:00 EST
Wiring version comparison into %config adds unnecessary
complication to rpm for little gain. Use triggers (with
versions) to rearrange the existing mix of files if
you *really* need this functionality.

Note You need to log in before you can comment on or make changes to this bug.