Bug 622059 - Author info is wrong in man page.
Author info is wrong in man page.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logrotate (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: ManPageChange
Depends On:
Blocks: 622451 659705
  Show dependency treegraph
 
Reported: 2010-08-06 18:26 EDT by Thomas Cameron
Modified: 2013-04-12 16:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: logrotate-3.7.4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 622451 (view as bug list)
Environment:
Last Closed: 2011-05-18 10:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (439 bytes, patch)
2010-08-09 08:07 EDT, Jan Kaluža
no flags Details | Diff

  None (edit)
Description Thomas Cameron 2010-08-06 18:26:25 EDT
Description of problem:
Author info is wrong in man page.

Version-Release number of selected component (if applicable):
The AUTHORS section of logrotate(8) shows two Red Hat employees who are not with the company any more, Erik Troan <ewt@redhat.com> and Preston Brown <pbrown@redhat.com>.  A customer mentioned it to me and it seems we might need to do something about it, although I am not sure what, exactly.

I know Erik is reachable at ewtroan@livejournal.com and I think Preston is at Bronto these days (http://www.bronto.com/company/leadership/preston-brown).

Do we amend or remove, or do those man pages need to be changed upstream?  I dug around for only a few minutes and I can't find anything which seems to be the official home page for logrotate.
Comment 1 Tomas Smetana 2010-08-09 07:57:14 EDT
Hello,
  logrotate lives on Fedora Hosted: https://fedorahosted.org/logrotate/

I believe the correct solution would be to remove the mail addresses (which are useless anyway) of the original logrotate authors, keep just their names in the documentation and add the contacts to the recent upstream. I don't think those gentlemen wish to be contacted with questions about logrotate.

Regards.
Comment 2 Jan Kaluža 2010-08-09 08:03:56 EDT
(In reply to comment #0)
> Description of problem:
> Author info is wrong in man page.
> 
> Version-Release number of selected component (if applicable):
> The AUTHORS section of logrotate(8) shows two Red Hat employees who are not
> with the company any more, Erik Troan <ewt@redhat.com> and Preston Brown
> <pbrown@redhat.com>.  A customer mentioned it to me and it seems we might need
> to do something about it, although I am not sure what, exactly.
> 
> I know Erik is reachable at ewtroan@livejournal.com and I think Preston is at
> Bronto these days (http://www.bronto.com/company/leadership/preston-brown).

I think the proper solution is to remove old emails from the man page. In my opinion it's not right to put their "private" emails there without any permission.

> Do we amend or remove, or do those man pages need to be changed upstream?  I
> dug around for only a few minutes and I can't find anything which seems to be
> the official home page for logrotate.    

Current official upstream is located at <https://fedorahosted.org/logrotate>. I've added that link to the man page as well as <logrotate-owner@fedoraproject.org> email, which is always forwarded to the actual logrotate package owner.
Comment 3 Jan Kaluža 2010-08-09 08:07:02 EDT
Created attachment 437578 [details]
proposed patch
Comment 4 RHEL Product and Program Management 2011-01-11 15:38:05 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 18:01:48 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 10 errata-xmlrpc 2011-05-18 10:58:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0816.html

Note You need to log in before you can comment on or make changes to this bug.