Bug 622064 - Support translations in product.img installclasses
Summary: Support translations in product.img installclasses
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-06 23:15 UTC by David Cantrell
Modified: 2010-11-10 19:52 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.21.72-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 19:52:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0002-Support-translations-from-product.img-files-622064.patch (1.30 KB, patch)
2010-08-06 23:20 UTC, David Cantrell
no flags Details | Diff
screenshot in French (64.63 KB, image/png)
2010-08-20 11:09 UTC, Alexander Todorov
no flags Details

Description David Cantrell 2010-08-06 23:15:12 UTC
The installclass translation files for product variants are provided in product.img files in the tree.  The attached patches modify anaconda so that those translation files are used just for the product variant strings.

Comment 1 David Cantrell 2010-08-06 23:20:23 UTC
Created attachment 437281 [details]
0002-Support-translations-from-product.img-files-622064.patch

Comment 2 Chris Lumens 2010-08-09 20:05:01 UTC
The one thing that worries me about the second blob is that we'll be passing yum an argument with a space in it, and that argument could get used for making directories and various other things.  Have you tested and verified that yum doesn't act too weirdly?

Comment 3 Dennis Gregorovic 2010-08-09 20:40:43 UTC
Good point.  I chatted with Seth and a space in the repo ID will break yum but a space in the repo Name is fine.  Unfortunately, at the moment getAddons() only returns a single value per addon which is used to set both the ID and Name.  So, we either need to:

 a) modify getAddons() to return separate ID and Name strings
 b) modify doConfigSetup() to string spaces from the repo ID
 c) revert that part of the patch altogether and translate the string without the space

I don't think c) will fly from a UI perspective.  Either a) or b) is fine with me.

Comment 4 Chris Lumens 2010-08-09 21:18:09 UTC
(a) seems the easiest and least error prone to me.

Comment 5 David Cantrell 2010-08-10 02:29:36 UTC
My vote is for (a) as well.  Chris, reassigning to you since you did _getAddons.

Comment 6 Chris Lumens 2010-08-10 15:58:54 UTC
Sent a patch to a-m-l:

https://www.redhat.com/archives/anaconda-devel-list/2010-August/msg00138.html

Tested with lang=de, and all the tasks are translated.  Repo names aren't, but the only repo I've got is "Red Hat Enterprise Linux" and that's a proper name.  Packages are now installing.

Comment 7 Dennis Gregorovic 2010-08-11 13:26:37 UTC
This looks good in the 0810.n.0 nightly.  Everything is translated including the repo names except for the "Red Hat Enterprise Linux" repo, which is expected.

Comment 9 Alexander Todorov 2010-08-20 11:09:37 UTC
Created attachment 439912 [details]
screenshot in French

Tested with 0818.0 build and lang=fr. All tasks and repo names are translated except Red Hat Enterprise Linux (base repo) which is expected. See attached screenshot.

Comment 10 releng-rhel@redhat.com 2010-11-10 19:52:52 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.