Bug 622070 - named.pid not found
named.pid not found
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-06 20:11 EDT by Dave Close
Modified: 2013-04-30 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
# rpm -V bind SM5...GT. c /etc/named.conf S.5....T. c /etc/sysconfig/named .M....G.. /usr/lib/bind missing /var/named/data missing /var/named/dynamic missing /var/named/slaves # cat /etc/sysconfig/named ROOTDIR=/var/named/chroot OPTIONS="-4"
Last Closed: 2010-08-16 03:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Close 2010-08-06 20:11:20 EDT
Description of problem:
On startup ("service named start"), the following message is sent to stderr:
  /etc/init.d/named: line 150: /var/named/chroot/var/run/named/named.pid: No such file or directory

Version-Release number of selected component (if applicable):
bind-9.7.1-2.P2.fc13.i686

How reproducible:
Every time

Steps to Reproduce:
1. service named [re]start
2.
3.
  
Actual results:


Expected results:


Additional info:
The service seems to be running. The command, "service named status" produces:

  version: 9.7.1-P2-RedHat-9.7.1-2.P2.fc13
  CPUs found: 2
  worker threads: 2
  number of zones: 6
  debug level: 0
  xfers running: 0
  xfers deferred: 0
  soa queries in progress: 0
  query logging is OFF
  recursive clients: 0/0/1000
  tcp clients: 0/100
  server is up and running
  named dead but subsys locked

Those last two lines are unsettling. How can the service be "up and
running" and "dead" at the same time? I presume the locked complaint is
related to the stderr message produced at startup.
Comment 1 Adam Tkac 2010-08-13 11:41:40 EDT
Would it be possible to tell me if you have "ROOTDIR" variable in /etc/sysconfig/named set and if you have "pid-file" directive in your named.conf, please?
Comment 2 Dave Close 2010-08-13 12:55:01 EDT
As indicated in the Environment section of this report, I suspected the package had been corrupted. I deleted it and re-installed. The problem is now gone so I can't answer the question. Thanks for your response and I apologize for the noise.
Comment 3 Adam Tkac 2010-08-16 03:27:28 EDT
(In reply to comment #2)
> As indicated in the Environment section of this report, I suspected the package
> had been corrupted. I deleted it and re-installed. The problem is now gone so I
> can't answer the question. Thanks for your response and I apologize for the
> noise.

Thanks for feedback, closing.

Note You need to log in before you can comment on or make changes to this bug.