Bug 622389 - The sysctl command's man page doesn't describe the option -A correctly.
The sysctl command's man page doesn't describe the option -A correctly.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Görig
BaseOS QE - Apps
: ManPageChange
Depends On:
Blocks: 627601
  Show dependency treegraph
 
Reported: 2010-08-09 03:46 EDT by Shinji Kito
Modified: 2015-01-13 15:56 EST (History)
7 users (show)

See Also:
Fixed In Version: procps-3.2.8-15.el6
Doc Type: Bug Fix
Doc Text:
Cause: non updated manual page Consequence: bad description of -A parameter Fix: manual page corrections Result: correct description of -A parameter
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:08:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinji Kito 2010-08-09 03:46:54 EDT
Description of problem:
The sysctl command's man page doesn't describe the option -A correctly.

-- RHEL6: sysctl man page--
  -A     Display all values currently available in table form.

-- RHEL5: sysctl man page--
  -A     Same as -a

sysctl.c has not changed since RHEL5.5, and RHEL6 man page should be the same
as the one in RHEL6.

Also, the following piece of code tells that -A and -a do the same thing.

procps-3.2.8/sysctl.c
<snip>
543          case 'a': // string and integer values (for Linux, all of them)
544          case 'A': // same as -a -o
545          case 'X': // same as -a -x
546               SwitchesAllowed = false;
547               return DisplayAll(PROC_PATH);
</snip>



Version-Release number of selected component (if applicable):
 Red Hat Enterprise Linux Version Number: RHEL 6
 Release Number: beta2 snapshot8
 Architecture: x86_64
 Kernel Version: kernel-2.6.32-52.el6.x86_64
 Related Package Version: procps-3.2.8-14.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
Just see the sysctl man page.

Actual results:
The sysctl command's man page doesn't describe the option -A correctly.

Expected results:
The sysctl command's man page describes the option -A correctly.


Additional info: 
Target Release: 6.1GA
Please see attached procps-3.2.7-sysctl-man-tbl.patch.
Comment 4 Jan Görig 2011-01-31 06:17:09 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: non updated manual page
Consequence: bad description of -A parameter
Fix: manual page corrections
Result: correct description of -A parameter
Comment 6 Branislav Náter 2011-03-01 08:27:35 EST
Bugfix (manual page update) was verified on package procps-3.2.8-16.el6.{i686,ppc64,s390x,x86_64}

Parameter -A is now described correctly. (Same as -a)
Comment 7 errata-xmlrpc 2011-05-19 10:08:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0708.html

Note You need to log in before you can comment on or make changes to this bug.