Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622397 - unable to bring up network in F14 RC2 KVM guest unless host firewall is disabled
unable to bring up network in F14 RC2 KVM guest unless host firewall is disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 04:23 EDT by Andre Robatino
Modified: 2010-08-11 09:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 09:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "ifconfig" on F14 x86_64 KVM guest after network error (9.54 KB, image/png)
2010-08-09 04:23 EDT, Andre Robatino
no flags Details
traceback when rescue mode attempts to bring up the network (i386) (9.00 KB, image/png)
2010-08-09 12:27 EDT, Andre Robatino
no flags Details
traceback when rescue mode attempts to bring up the network (x86_64) (9.11 KB, image/png)
2010-08-09 12:28 EDT, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2010-08-09 04:23:29 EDT
Created attachment 437540 [details]
output of "ifconfig" on F14 x86_64 KVM guest after network error

Description of problem:
When trying to install F14 x86_64 RC2 as a KVM guest on a F13 x86_64 host, immediately after writing partitioning options to disk, a window pops up "Select network interface" which says "This requires that you have an active network connection during the installation process.  Please configure a network interface.".  Clicking on "OK", a "Network Connections" window comes up, with an "Auto eth0" entry.  I click on "Close", get a "Waiting for NetworkManager to activate these devices: eth0" message, then after a wait, pops up window titled "Error Enabling Network", which says "An error occurred trying to bring up the eth0 network interface.".  Going to VT2, the ifconfig command shows that eth0 is already up.

I tried disabling the firewall completely on the host with no difference.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-1.fc14.x86_64

How reproducible:
always
Comment 1 Andre Robatino 2010-08-09 11:47:53 EDT
Am also unable to do the test

https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_bugzilla

due to failure to bring up the network in order to retrieve the file traceback.img.
Comment 2 Andre Robatino 2010-08-09 12:27:32 EDT
Created attachment 437642 [details]
traceback when rescue mode attempts to bring up the network (i386)
Comment 3 Andre Robatino 2010-08-09 12:28:12 EDT
Created attachment 437644 [details]
traceback when rescue mode attempts to bring up the network (x86_64)
Comment 4 Andre Robatino 2010-08-09 12:51:48 EDT
If I disable the host firewall before starting the guest, then the guest can access the network.  Going to VT2, ifconfig eth0 now shows an extra line with a local IPv4 IP address.
Comment 5 Andre Robatino 2010-08-11 09:25:15 EDT
Seems to be fixed in RC3.

Note You need to log in before you can comment on or make changes to this bug.