Bug 622415 - [REF] integration to TCMS
[REF] integration to TCMS
Status: CLOSED DUPLICATE of bug 741608
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
devel
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks: 596770
  Show dependency treegraph
 
Reported: 2010-08-09 05:53 EDT by Victor Chen
Modified: 2014-10-12 18:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-20 06:50:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victor Chen 2010-08-09 05:53:04 EDT
Description of problem:
Hi

Is there any plan to have integration done also in Bugzilla?
I mean automatic linking from BZ -> TCMS, when bug is assigned to TCMS test case
This would probably require:
- new bugzilla field created - visible to RH employees only
- test case link(s), if present, will be displayed in bug report

It would be really neat feature, saving time and typos when manually editing BZ fields (QA Whiteboard).

-- 
Ondrej 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Hudlicky 2010-08-09 10:21:06 EDT
+1    proposing to denominate the field: Test Case (cf_testcase)
Ideally if just test cases numbers in field are editable and TCMS links are generated from it. 

TCMS/Nitrate would periodically:
1. query BZ for updated bugs to save Bug->TCMS relation to its database
2. the other way around - update bug records with new test case numbers
Consistent [Bug,TestCase] data should be then present in both databases.
Comment 2 David Lawrence 2010-08-09 14:52:46 EDT
(In reply to comment #1)
> +1    proposing to denominate the field: Test Case (cf_testcase)
> Ideally if just test cases numbers in field are editable and TCMS links are
> generated from it. 
> 
> TCMS/Nitrate would periodically:
> 1. query BZ for updated bugs to save Bug->TCMS relation to its database
> 2. the other way around - update bug records with new test case numbers
> Consistent [Bug,TestCase] data should be then present in both databases.    

instead of using a new custom field, we can utilize the External Trackers table and just have a link created their to the TCMS case or test run. Future support will be in Bugzilla to get status from TCMS and also to send changes to bug reports to TCMS as long as the links exist in the External Tracker table. For simple linking as a place holder, we can do that now with current Bugzilla.

Dave
Comment 3 Ondrej Hudlicky 2010-08-10 04:45:31 EDT
Thanks for quick reply/. External Bugs table sounds like good short term solution.

We definitely need "TCMS test case" option there. 
Using "TCMS test case run" is also a worth adding, but mostly we want to see:
- link to all test case runs, where test case failed
- link to all test case runs, where test case passed 
- link to all test case runs in progress 
I am not sure if future of TCMS<->BZ integration should include these links in BZ interface or of it is unnecessary overhead. Probably better if these links are just available from test case summary in TCMS.
Comment 4 Petr Šplíchal 2010-08-17 09:49:23 EDT
[We could probably merge this with bug 596770].
Comment 6 Simon Green 2012-05-20 06:50:34 EDT

*** This bug has been marked as a duplicate of bug 741608 ***

Note You need to log in before you can comment on or make changes to this bug.