This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 622488 - [vdsm] [libvirt] time-out is not enforced on vms pending on 'wait for launch' state
[vdsm] [libvirt] time-out is not enforced on vms pending on 'wait for launch'...
Status: CLOSED DUPLICATE of bug 625343
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Dan Kenigsberg
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 10:02 EDT by Haim
Modified: 2016-04-18 02:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-21 11:11:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Haim 2010-08-09 10:02:17 EDT
Description of problem:

time-out is not enforced for vms that are stuck on 'wait for launch' state in current version (we had it in earlier version without libvirt). 
currently, vms can be hanged for hours (till rhevx will kill them), 

how ? 

1) make sure to have an host connected to iscsi storage 
2) kill -STOP `pgrep libvirt` 
3) start new vm 

result: 

vm will be hanged in 'wait for launch' 

spoke to Danken and he's aware of this problem. 

vdsm-4.9-12.el6.x86_64
libvirt-0.8.1-21.el6.x86_64
qemu-kvm-0.12.1.2-2.108.el6.x86_64
Comment 1 Haim 2010-08-09 10:08:05 EDT
note: also for vms stuck in 'saving state'!
Comment 3 Barak 2010-11-21 11:11:42 EST

*** This bug has been marked as a duplicate of bug 625343 ***

Note You need to log in before you can comment on or make changes to this bug.