Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622561 - authentication method buttons show and disappear before they can be used
authentication method buttons show and disappear before they can be used
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 14:45 EDT by jmccann
Modified: 2015-01-14 18:25 EST (History)
4 users (show)

See Also:
Fixed In Version: gdm-2.30.4-29.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 13:08:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1721 normal SHIPPED_LIVE gdm bug fix update 2011-12-05 20:02:11 EST

  None (edit)
Description jmccann 2010-08-09 14:45:44 EDT
In the latest gdm the authentication method buttons (password, fingerprint, etc) show up when clicking the user's name and disappear before they can be used.
Comment 1 Ray Strode [halfline] 2010-08-09 14:49:45 EDT
So what's going on here is,

- you don't have smartcards enabled
- you don't have a fingerprint reader

The authentication buttons show up briefly because you do have fingerprint authentication enabled, but then fails shortly there after since you don't have a reader.

The gdm code won't show the authentication method buttons if you only have one authentication method available.

We could probably avoid showing the buttons at all if you don't have a fingerprint reader.  That would likely require changes to fprintd and the gdm fingerprint plugin.

It's not blocker material at this point, though.
Comment 4 RHEL Product and Program Management 2011-05-13 19:07:19 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 9 errata-xmlrpc 2011-12-06 13:08:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1721.html

Note You need to log in before you can comment on or make changes to this bug.