Bug 62266 - dangling symlinks
dangling symlinks
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: qt2 (Show other bugs)
skipjack-beta2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Brock Organ
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-28 18:23 EST by Vladimir Ivanovic
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 14:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Ivanovic 2002-03-28 18:23:09 EST
Description of Problem: installation leaves some symlinks pointing nowhere


Version-Release number of selected component (if applicable):


How Reproducible: always


Steps to Reproduce:
1. symlinks -r / | egrep dangling
2. 
3. 

Actual Results:
dangling: /usr/share/doc/HTML/en/kwordtrans -> ../../wordtrans-doc/html.en/
dangling: /usr/share/doc/HTML/es/kwordtrans -> ../../wordtrans-doc/html.es/
dangling: /usr/share/doc/HOWTO/other-formats/docbook/XML-RPC-HOWTO.sgml.gz ->
XML-RPC-HOWTO.xml.gz
dangling: /usr/share/doc/svgalib-1.4.1/README.lrmi -> ../lrmi-0.6m/README
dangling: /usr/bin/moc2 -> ../lib/qt2-2.3.1/bin/moc
dangling: /usr/bin/findtr2 -> ../lib/qt2-2.3.1/bin/findtr
dangling: /usr/bin/makeqpf2 -> ../lib/qt2-2.3.1/bin/makeqpf
dangling: /usr/bin/mergetr2 -> ../lib/qt2-2.3.1/bin/mergetr
dangling: /usr/bin/msg2qm2 -> ../lib/qt2-2.3.1/bin/msg2qm
dangling: /usr/bin/qconfig2 -> ../lib/qt2-2.3.1/bin/qconfig
dangling: /usr/bin/qt20fix2 -> ../lib/qt2-2.3.1/bin/qt20fix
dangling: /usr/bin/qtrename1402 -> ../lib/qt2-2.3.1/bin/qtrename140
dangling: /usr/bin/uic2 -> ../lib/qt2-2.3.1/bin/uic
dangling: /usr/bin/designer2 -> ../lib/qt2-2.3.1/bin/designer
dangling: /usr/lib/libpbm.so -> libpbm.so
dangling: /usr/lib/libpgm.so -> libpgm.so
dangling: /usr/lib/libpnm.so -> libpnm.so
dangling: /usr/lib/libppm.so -> libppm.so
dangling: /usr/lib/libglide3.so -> libglide3.so.3.10.0
dangling: /usr/sbin/squid-config -> consolehelper



Expected Results:
(none)

Additional Information:
Comment 1 Nathan G. Grennan 2002-04-01 02:02:35 EST
I tried running symlinks as you did and got nothing back in output. I am sure I
have some of the same packages installed that show up in your list. One
difference may be that I am running with all the updates for skipjack from up2date.
Comment 2 Bill Nottingham 2002-04-01 11:35:04 EST
Assigning to qt2... those are the ones that seem most obviously wrong.
Comment 3 Josep L. Guallar-Esteve 2002-04-02 14:02:00 EST
I think this information is relevant to this bug:

* test tree Skipjack-re0401.0 i386

I found dangling symlinks too:


520|0 6 27389 1 22|Test-Failure: tp6: /usr/bin/findtr2: dangling symlink
520|0 6 27389 1 23|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 24|Test-Failure: tp6: /usr/bin/makeqpf2: dangling symlink
520|0 6 27389 1 25|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 26|Test-Failure: tp6: /usr/bin/mergetr2: dangling symlink
520|0 6 27389 1 27|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 28|Test-Failure: tp6: /usr/bin/moc2: dangling symlink
520|0 6 27389 1 29|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 30|Test-Failure: tp6: /usr/bin/msg2qm2: dangling symlink
520|0 6 27389 1 31|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 32|Test-Failure: tp6: /usr/bin/qconfig2: dangling symlink
520|0 6 27389 1 33|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 34|Test-Failure: tp6: /usr/bin/qt20fix2: dangling symlink
520|0 6 27389 1 35|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 36|Test-Failure: tp6: /usr/bin/qtrename1402: dangling symlink
520|0 6 27389 1 37|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 38|Test-Failure: tp6: /usr/bin/uic2: dangling symlink
520|0 6 27389 1 39|Owning package: qt2-devel-2.3.1-2
520|0 6 27389 1 40|Test-Failure: tp6: /usr/bin/designer2: dangling symlink
520|0 6 27389 1 41|Owning package: qt2-designer-2.3.1-2


 Source RPM: qt2-2.3.1-2.src.rpm
Comment 4 Vladimir Ivanovic 2002-04-02 14:09:39 EST
I may have jumped the gun here (apologies if I have) since some the dangling
symlinks I reported may have been left over from a previous clean 7.2 installation. 

A test case would be to do a clean install and see if there are any dangling
symlinks, but I don't have a spare machine on which to do it. 

I will check the dates on my current crop of dangling symlinks and report if any
are recent, and install a cronjob to check nightly for any new ones.
Comment 5 Josep L. Guallar-Esteve 2002-04-02 14:32:53 EST
My report is from a clean installation:

* test tree Skipjack-re0401.0 i386
* test case i386/English/Everything/NFS/GUI

# uname -mrs
Linux 2.4.18-0.12 i686
# rpm -qa | grep qt
qt-designer-3.0.3-6
qt-MySQL-3.0.3-6
qtcups-devel-2.0-5
qt2-Xt-2.3.1-2
qt2-designer-2.3.1-2
qt-3.0.3-6
qt-PostgreSQL-3.0.3-6
qt2-static-2.3.1-2
qt1x-1.45-16
qt2-devel-2.3.1-2
qt1x-devel-1.45-16
qt-static-3.0.3-6
qtcups-2.0-5
qt2-2.3.1-2
qt1x-GL-1.45-16
qt-Xt-3.0.3-6
qt-devel-3.0.3-6
licq-qt-1.0.4-2
qt-ODBC-3.0.3-6
wordtrans-qt-1.1pre8-6

Comment 6 Bernhard Rosenkraenzer 2002-04-10 12:44:53 EDT
Fixed in qt2-2.3.1-3

Note You need to log in before you can comment on or make changes to this bug.