Bug 622712 - cryptsetup hangs when isLuks is used on ordinary file
cryptsetup hangs when isLuks is used on ordinary file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cryptsetup-luks (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Milan Broz
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 04:35 EDT by Pavel Holica
Modified: 2013-02-28 23:09 EST (History)
6 users (show)

See Also:
Fixed In Version: cryptsetup-luks-1.0.3-6.el5
Doc Type: Bug Fix
Doc Text:
The cryptsetup utility became unresponsive when using the "cryptsetup isLuks" command on an ordinary file. This problem has been fixed: if running the command on an ordinary file, the cryptsetup utility informs users about the file not being a LUKS partition.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 03:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Holica 2010-08-10 04:35:23 EDT
Description of problem:
Running cryptsetup isLuks on ordinary file causes cryptsetup to hang.

Version-Release number of selected component (if applicable):
RHEL 5.5 Server x86_64
cryptsetup-luks-1.0.3-5.el5

How reproducible:
always

Steps to Reproduce:
1. echo foo > /tmp/foo
2. cryptsetup isLuks /tmp/foo
  
Actual results:
crypsetup hang consuming 95% of CPU

Expected results:
Cannot read device /tmp/foo

Additional info:
Comment 1 RHEL Product and Program Management 2010-08-10 04:37:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 Milan Broz 2011-03-08 06:10:44 EST
Fixed in
cryptsetup-luks-1.0.3-6.el5
Comment 7 Alexander Todorov 2011-05-11 09:35:15 EDT
# rpm -q cryptsetup-luks
cryptsetup-luks-1.0.3-8.el5

# echo foo > /tmp/foo
# cryptsetup isLuks /tmp/foo 
/tmp/foo is not a LUKS partition
# echo $?
234
#
Comment 8 Eliska Slobodova 2011-07-07 12:07:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The cryptsetup utility became unresponsive when using the "cryptsetup isLuks" command on an ordinary file. This problem has been fixed: if running the command on an ordinary file, the cryptsetup utility informs users about the file not being a LUKS partition.
Comment 9 errata-xmlrpc 2011-07-21 03:04:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0987.html

Note You need to log in before you can comment on or make changes to this bug.