Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622735 - Bug.search misbehaving
Bug.search misbehaving
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Jeff Fearn
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 05:43 EDT by Shreyank Gupta
Modified: 2013-06-23 23:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 01:20:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shreyank Gupta 2010-08-10 05:43:32 EDT
Description of problem:

* Although the Bug.get webservice docs mention 'status' as a parameter, in fact 'status' does not work. Instead 'bug_status' works properly as a parameter. In such a scenario, either the docs need to be updated or the webservice.

* 'summary' does not work as a parameter, also tried using 'short_desc' but no avail.

* These are only two parameters I tested. Although the docs mention unstable, Bug.search is a very important method and must be more robust if we are gong to move to the upstream webservices soon.
Comment 1 David Lawrence 2010-08-10 12:39:28 EDT
Yes the documentation for Bug.search is for the upstream of Bug.search and not the actual one Red Hat is using. We renamed the upstream version to Bug.search_new (if you want to try it) and the actual Bug.search is the same as our bugzilla.runQuery in that it takes the same params as the query.cgi web UI form. So use bugzilla.runQuery's documentation for Bug.search. Also you will need to use short_desc and bug_status instead of summary and status that the upstream Bug.search_new uses. The reason we did all this is the Bug.search implemented by upstream in 3.6 is very limited in what you can do.

I will update the documentation to reflect all of this properly before Friday. Also FWIW, the upstream is revising Bug.search to be like query.cgi like we do now but it is not in 3.6 and will likely be in 4.0 later this year.

https://bugzilla.redhat.com/show_bug.cgi?id=622735

Dave
Comment 2 Shreyank Gupta 2010-08-11 05:14:35 EDT
(In reply to comment #1)
> Yes the documentation for Bug.search is for the upstream of Bug.search and not
> the actual one Red Hat is using. We renamed the upstream version to
> Bug.search_new (if you want to try it) and the actual Bug.search is the same as
> our bugzilla.runQuery in that it takes the same params as the query.cgi web UI
> form. So use bugzilla.runQuery's documentation for Bug.search. Also you will
> need to use short_desc and bug_status instead of summary and status that the
> upstream Bug.search_new uses. The reason we did all this is the Bug.search
> implemented by upstream in 3.6 is very limited in what you can do.
> 
Very well, seems Bug.search(actually bugzilla.runQuery) matches full 'short_desc' and not like 'summary' matches in Bug.search is supposed to do. But I can live with that. Also I tried testing Bug.search_new, but it throws out unexpected faults,

> bz._proxy.Bug.search_new({'product': 'Software Test Suite', 'component': 'rhel-abi-assurance', 'status':'CLOSED', 'summary': 'request'})

returns:
<Fault 53: 'WHERE is not a valid parameter for the Bugzilla::Bug::match function.'>

> bz._proxy.Bug.search_new({'product': 'Software Test Suite', 'component': 'rhel-abi-assurance', 'status':'CLOSED'})

returns:
<Fault -32000: 'Can\'t use string ("") as an ARRAY ref while "strict refs" in use at /var/www/html/bugzilla/Bugzilla/WebService/Bug.pm line 1398.\n'>

> I will update the documentation to reflect all of this properly before Friday.
> Also FWIW, the upstream is revising Bug.search to be like query.cgi like we do
> now but it is not in 3.6 and will likely be in 4.0 later this year.
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=622735
> 
Did you mean to give me some other bug URL? Because this one is of the present  bug's.
Comment 4 Jeff Fearn 2012-05-30 00:44:36 EDT
As part of the recent Bugzilla 4.2 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 5 Jeff Fearn 2012-05-30 00:44:50 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 6 Simon Green 2012-05-30 01:20:32 EDT
These issues were fixed in Bugzilla 4.2

Note You need to log in before you can comment on or make changes to this bug.