Bug 62274 - Unable to execute in.telnet manually with arguments
Unable to execute in.telnet manually with arguments
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: telnet (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 19:13 EST by Jaroslaw Sosnicki
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 19:13:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2002-03-28 19:13:48 EST
Description of Problem:
[root@localhost root]# /usr/sbin/in.telnetd
/usr/sbin/in.telnetd: getpeername: Socket operation on non-socket
[root@localhost root]# /usr/sbin/in.telnetd 8001
Usage: telnetd [-debug] [-D (options|report|exercise|netdata|ptydata)]
	 [-h] [-L login_program] [-n] [port]
[root@localhost root]# /usr/sbin/in.telnetd -debug
bind: Address already in use

Since all arguments are optional this command should start normaly without eny
errors with any compination of the command line arguments.


Version-Release number of selected component (if applicable):
[root@localhost root]# rpm -qa |grep telnet
telnet-server-0.17-20
telnet-0.17-20

How Reproducible:
/usr/sbin/in.telnet

it works when started as folows:
/usr/sbin/in.telnet -debug 8001

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Harald Hoyer 2002-04-02 03:59:48 EST
TELNETD(8)                  System Manager's Manual                 TELNETD(8)

NAME
     telnetd - DARPA telnet protocol server

SYNOPSIS
     /usr/sbin/in.telnetd [-hns] [-a authmode] [-D debugmode] [-L loginprg]
                          [-S tos] [-X authtype] [-edebug] [-debug port]


Note You need to log in before you can comment on or make changes to this bug.