Bug 622810 - LUKS partition unreadable after latest update to updates-testing
Summary: LUKS partition unreadable after latest update to updates-testing
Status: CLOSED DUPLICATE of bug 622385
Alias: None
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 13:16 UTC by Maximiliano Bertacchini
Modified: 2010-08-10 13:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 13:36:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of error from bug #620202 Comment 8 (52 bytes, text/plain)
2010-08-10 13:20 UTC, Maximiliano Bertacchini
no flags Details

Description Maximiliano Bertacchini 2010-08-10 13:16:38 UTC
Description of problem:
After updating to device-mapper-1.02.53-4.fc13.x86_64, the system was unable to mount a LUKS partition and exited to an emergency shell (see attached image from bug #620202). Kernel was updated to kernel-2.6.34.2-34.fc13.x86_64 in the same yum transaction. Tried reverting to device-mapper*-1.02.44-1.fc13.i686.rpm and the system booted successfully. I later found out it could boot with latest device-mapper but previous version of "/lib/udev/rules.d/10-dm.rules". I finally tried rebuilding the initramfs (i.e. dracut --force) and it fixed the issue. According to /var/log/yum.log the new kernel was installed before the device-mapper update, so I guess the initramfs needed an extra update.

Version-Release number of selected component (if applicable):
device-mapper-1.02.53-4.fc13.x86_64

How reproducible:

Steps to Reproduce:
1. yum upgrade (updates-testing repo enabled)
2. reboot
  
Actual results:
LUKS partition not found.
Message: "fsck.ext4: No such file or directory while trying to open /dev/mapper/luks-VolGroup00-lvhome"

Expected results:
Successful boot

Additional info:
See bug #620202 which describes the same issue in Comment 7.

Comment 1 Maximiliano Bertacchini 2010-08-10 13:20:37 UTC
Created attachment 437873 [details]
Photo of error from bug #620202  Comment 8

Comment 2 Milan Broz 2010-08-10 13:36:01 UTC
Current lvm2/dm build in F13 updates is broken and is already removed from testing repo, I hope new update will be ready soon.

*** This bug has been marked as a duplicate of bug 622385 ***


Note You need to log in before you can comment on or make changes to this bug.