Bug 622865 - QMF agent should throttle back connection and object updates when queue full detected.
QMF agent should throttle back connection and object updates when queue full ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
beta
All Linux
low Severity high
: Next Version
: ---
Assigned To: Ken Giusti
MRG Quality Engineering
:
Depends On: 623805
Blocks: 615441
  Show dependency treegraph
 
Reported: 2010-08-10 11:30 EDT by Ken Giusti
Modified: 2011-08-12 12:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-10 09:24:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backoff reconnect attempt if connection dropped due to queue limit violation. (3.91 KB, patch)
2010-08-12 13:38 EDT, Ken Giusti
no flags Details | Diff

  None (edit)
Description Ken Giusti 2010-08-10 11:30:07 EDT
Description of problem:

The QMF agent effectively ignores queue resource exhaustion events.  Currently, the agent will immediately reconnect and continue publishing data when a queue exhaustion exception occurs.  This behavior exacerbates the queue saturation problem by creating additional unsolicited management messages (binding, etc).

Version-Release number of selected component (if applicable):
Beta

How reproducible:
100%


Steps to Reproduce:
1. See https://bugzilla.redhat.com/show_bug.cgi?id=615441
2.
3.
  
Actual results:
The QMF agent immediately re-connects and continues publishing object status messages.

Expected results:
The agent should handle the exception more gracefully by backing off the reconnection attempt, and further by delaying the next object update cycle/throttle back the number of objects published.

Additional info:
Comment 1 Ken Giusti 2010-08-12 13:38:52 EDT
Created attachment 438490 [details]
Backoff reconnect attempt if connection dropped due to queue limit violation.

I've tried the above patch in testing in my high traffic/slow consumer setup - there was no noticible improvement to performance when simply backing off the reconnect attempt.   Including patch for reference - not submitting it as a fix.

Note You need to log in before you can comment on or make changes to this bug.