Bug 622976 - No option to mount encrypted partition
Summary: No option to mount encrypted partition
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udisks   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 23:23 UTC by Felipe Contreras
Modified: 2013-03-06 04:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 17:55:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Contreras 2010-08-10 23:23:42 UTC
I open palimpsest, select an encrypted partition, I see the option to "unlock" the volume... what's the point of that?

The interesting option is to *mount* the partition, and that's not anywhere.

Comment 1 David Zeuthen 2010-08-11 17:55:22 UTC
Palimpsest is doing the right thing by presenting this interface. FYI partition with the LUKS data on could contain a host of other things (swap, LVM PV, RAID member, etc.) that cannot even be mounted. That's why you need to unlock and then you can do whatever you want with the cleartext device.

Comment 2 Felipe Contreras 2010-08-11 18:08:01 UTC
(In reply to comment #1)
> Palimpsest is doing the right thing by presenting this interface. FYI partition
> with the LUKS data on could contain a host of other things (swap, LVM PV, RAID
> member, etc.) that cannot even be mounted. That's why you need to unlock and
> then you can do whatever you want with the cleartext device.    

Ok, first unlock, then mount... where's the option to mount?

Comment 3 David Zeuthen 2010-08-11 19:19:31 UTC
Just select the unlocked object in the user interface and press the Mount button. Like here

 http://people.freedesktop.org/~david/palimpsest-newui-luks2.png

only this shows an Unmount button because the filesystem is already mounted (if unmounted, that button turns into a Mount button).

Comment 4 Felipe Contreras 2010-08-12 01:15:57 UTC
Ahh, I didn't notice it was split in two.

However, if the file-system has no label, shouldn't it pick the volume name?


Note You need to log in before you can comment on or make changes to this bug.