Bug 622994 - [abrt] crash in terminator-0.94-1.fc13: searchbar.py:158:prev_search:TypeError: expected a character buffer object
[abrt] crash in terminator-0.94-1.fc13: searchbar.py:158:prev_search:TypeErro...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: terminator (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
abrt_hash:09044180
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 22:01 EDT by Chao Ye
Modified: 2010-12-13 16:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 16:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (601 bytes, text/plain)
2010-08-10 22:01 EDT, Chao Ye
no flags Details

  None (edit)
Description Chao Ye 2010-08-10 22:01:29 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/terminator
component: terminator
executable: /usr/bin/terminator
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: terminator-0.94-1.fc13
reason: searchbar.py:158:prev_search:TypeError: expected a character buffer object
release: Fedora release 13 (Goddard)

backtrace
-----
searchbar.py:158:prev_search:TypeError: expected a character buffer object

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/terminatorlib/searchbar.py", line 158, in prev_search
    index = buffer.find(self.searchstring)
TypeError: expected a character buffer object

Local variables in innermost frame:
buffer: '                                                                          CP:'
startrow: 2184
widget: <gtk.Button object at 0x20c7e60 (GtkButton at 0x238f8d0)>
self: <Searchbar object at 0x20c78c0 (terminatorlib+searchbar+Searchbar at 0x238b3f0)>
endrow: 2684
Comment 1 Chao Ye 2010-08-10 22:01:31 EDT
Created attachment 438053 [details]
File: backtrace
Comment 2 Dominic Hopf 2010-08-11 16:24:49 EDT
Hi ChaoYe,
thanks for reporting this issue. Do you have some steps to reproduce or is this a sporadic crash?

Regards,
Dominic
Comment 3 Chao Ye 2010-08-11 21:13:06 EDT
Hi Dominic,
I totally have no idea how to reproduce it. It just crashed.
I guess it maybe due to I spited some windows and tabs. In most times, it crashed when there are many tabs and windows. In most time, I have two tabs, and each tab got four windows.

Regards,
ChaoYe
Comment 4 Chao Ye 2010-08-11 21:15:29 EDT
Just got another crash, here is the backtrace:
================================================================================

titlebar.py:105:update:AttributeError: 'str' object has no attribute 'group'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/terminatorlib/window.py", line 189, in on_focus_out
    terminal.on_window_focus_out()
  File "/usr/lib/python2.6/site-packages/terminatorlib/terminal.py", line 986, in on_window_focus_out
    self.titlebar.update('window-focus-out')
  File "/usr/lib/python2.6/site-packages/terminatorlib/titlebar.py", line 105, in update
    if term != other and term.group and term.group == other.group:
AttributeError: 'str' object has no attribute 'group'

Local variables in innermost frame:
default_bg: False
term: <Terminal object at 0x2af68c0 (terminatorlib+terminal+Terminal at 0x23e8bf0)>
other: 'window-focus-out'
terminator: <terminatorlib.terminator.Terminator instance at 0x2afe3f8>
self: <Titlebar object at 0x2af6fa0 (terminatorlib+titlebar+Titlebar at 0x23e8d10)>
Comment 5 Dominic Hopf 2010-08-16 17:29:22 EDT
Guess you also don't know how to reproduce this one? :S
I'll report the issues to upstream, at the latest next week.

I'm sorry for my spare time at present, just began a new job in July. I promise that will get better. :)
Comment 6 Dominic Hopf 2010-08-28 09:50:03 EDT
Before I report this to upstream... There is a new version 0.95 of Terminator available since Thursday last week. I already built it and it's available in updates-testing repository. It would be cool if you could try reproducing the issue with the new version. Maybe it's already fixed. :)
Comment 7 Dominic Hopf 2010-12-11 16:34:01 EST
Hi ChaoYe, since I didn't got any feedback since may last reply in August, I assume this issue was either fixed with Terminator 0.95 or your not interested in tracking this issue anymore. You know, without a way to reproduce I'm not able to act on the issue. I'll flag this with NEEDINFO for now. If I don't get a reply within the next 30 days I think it will be fine to close this issue.
Comment 8 Chao Ye 2010-12-12 21:44:28 EST
Hi Dominic, I'm using F14 now. And terminator works fine, no crash occurs. I guess it's fine to close this issue.
Comment 9 Dominic Hopf 2010-12-13 16:52:43 EST
Thanks for your feedback :)

Note You need to log in before you can comment on or make changes to this bug.