Bug 623172 - virt-v2v does not update the default kernel configuration
Summary: virt-v2v does not update the default kernel configuration
Status: CLOSED DUPLICATE of bug 609526
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-11 14:19 UTC by Gunther Schlegel
Modified: 2010-09-06 09:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-06 09:52:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gunther Schlegel 2010-08-11 14:19:38 UTC
Description of problem:

When installing a new kernel, grubby will only activate it if the package matches the DEFAULTKERNEL definition in /etc/sysconfig/kernel.

The default kernel on a paravirtualized XEN-VM is "kernel-xen".
The default kernel on a KVM-VM is "kernel".

virt-v2v does change the installed kernel and updates the grub configuration, but does not update /etc/sysconfig/kernel accordingly. Therefore updated kernel are not activated by default.

Version-Release number of selected component (if applicable):
virt-v2v-0.6.1-2.el5

How reproducible:
Migrate a paravirtualized VM from XEN to RHEV / KVM.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
/etc/sysconfig/kernel contains "DEFAULTKERNEL=kernel-xen"

Expected results:
/etc/sysconfig/kernel contains "DEFAULTKERNEL=kernel"

Additional info:

Comment 1 Richard W.M. Jones 2010-08-11 14:30:55 UTC
I was so sure that we did this already, but I have
just checked the upstream code and this file is not
touched.

Comment 2 Matthew Booth 2010-09-06 09:52:34 UTC

*** This bug has been marked as a duplicate of bug 609526 ***


Note You need to log in before you can comment on or make changes to this bug.