Bug 623195 - [PATCH/RFC] Move jmx_ plugin to java-plugins package
Summary: [PATCH/RFC] Move jmx_ plugin to java-plugins package
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: munin   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-11 14:55 UTC by Todd Zullinger
Modified: 2010-08-12 20:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 20:49:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Move jmx_ plugin to java-plugins package (1.35 KB, application/octet-stream)
2010-08-11 14:55 UTC, Todd Zullinger
no flags Details

Description Todd Zullinger 2010-08-11 14:55:17 UTC
Created attachment 438209 [details]
Move jmx_ plugin to java-plugins package

I noticed that the jmx_ plugin is included in munin-node (only because I had packaged an earlier version of this as munin-plugin-jmx and the newer munin-node conflicts).  It seems to me that the jmx_ plugin is better placed in the java-plugins package.

Attached is a patch that does so, made against the master branch in git (i.e. rawhide).  This should easily apply using git am /path/to/patch, which will apply the patch and commit it locally (it won't push it, so it affects only the local git clone).

A scratch build is at:

    http://koji.fedoraproject.org/koji/taskinfo?taskID=2393416

It looks right to me, moving only %{_datadir}/munin/plugins/jmx_ from munin-node to munin-java-plugins.  If I'm missing a good reason why jmx_ is in munin-node, feel free to close this. :)

Comment 1 Kevin Fenzi 2010-08-12 19:59:54 UTC
I've applied this in rawhide. ;) 

Thanks!

Do you think this warrents a update in stable releases? 
The conflict you note should not happen for regular fedora users, would it?

Comment 2 Todd Zullinger 2010-08-12 20:35:31 UTC
Thanks Kevin.  I don't think there's any reason to push this to stable branches.  It can wait for the next upstream update or bugfix.  As you note, unless someone has packaged up an older jmx plugin, they'll never run into this.  It's just a minor cleanup. :)

Comment 3 Kevin Fenzi 2010-08-12 20:49:16 UTC
Cool. Thanks for the note and patch. 

Built in: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=189945

Closing this now. Will push this change out on next update to stable releases.


Note You need to log in before you can comment on or make changes to this bug.