Bug 623217 - [Intel 6.0 bug] Device ID string for device 0x10ED is incorrect
Summary: [Intel 6.0 bug] Device ID string for device 0x10ED is incorrect
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hwdata   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: 6.0
Assignee: Karsten Hopp
QA Contact: Eduard Benes
URL:
Whiteboard:
Keywords:
: 625700 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-11 16:10 UTC by John Ronciak
Modified: 2010-11-10 20:39 UTC (History)
7 users (show)

Fixed In Version: hwdata-0.233-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 20:39:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ronciak 2010-08-11 16:10:47 UTC
Description of problem: The string identifies the device as an 82559 and it is an 82599 device.  This is the Virtual Function device for the ixgbevf driver.

I've submitted a change request to the PCI ID's maintainer to correct this.  Hopefully it won't take too long to get this corrected.  If it's done in time the adjusted ID's will be picked up when the RHEL6 ID's adjusted in Aug. 25th.

Comment 3 RHEL Product and Program Management 2010-08-11 16:38:36 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Peter Martuccelli 2010-08-11 17:03:08 UTC
Nothing to do in the kernel for this, we will monitor the final pci-id pull for R6.

Comment 5 Andy Gospodarek 2010-08-11 17:32:05 UTC
I think this should be under the hwdata component.

Comment 6 Karsten Hopp 2010-08-16 09:45:10 UTC
Latest upstream pci.ids has the correct description for 8086:10ED

Comment 9 John Ronciak 2010-08-19 16:31:50 UTC
I just checked this and it's still wrong.  I went to:

http://pci-ids.ucw.cz/read/PC/8086

and it's showing it still listed as 82559.  I'm sending Martin Mares mail to accept the change I submitted last week.

Comment 10 Karsten Hopp 2010-08-20 09:30:16 UTC
*** Bug 625700 has been marked as a duplicate of this bug. ***

Comment 11 John Ronciak 2010-08-23 10:01:47 UTC
The ID upstream has been corrected so when the ID's are once again on the 25th, the string will be correct.

Comment 14 Ronald Pacheco 2010-09-27 02:36:26 UTC
Has Intel verifed this BZ?  If so, please set the verified flag.  Thanks!

Comment 15 John Ronciak 2010-09-27 22:33:10 UTC
The ID string in now correct in RC1.

Comment 16 releng-rhel@redhat.com 2010-11-10 20:39:14 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.