Bug 62342 - no /usr/bin/lpr
no /usr/bin/lpr
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: LPRng (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 16:50 EST by ellson
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 11:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ellson 2002-03-29 16:50:06 EST
Description of Problem:
There was no /usr/bin/lpr on my system.
It doesn't seem to be created from any rpm
The config tool "redhat-switch-printer" doesn't create one.  

I was able to get printing working with "ln -s /usr/bin/lpr.LPRng /usr/bin/lpr"

Version-Release number of selected component (if applicable):
LPRng-3.8.9-2


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Sammy 2002-04-01 08:49:36 EST
I did the same on my system. I am surprised this had not been reported
from -1 to -2. Is there a reason  for this name change?
Comment 2 Bill Nottingham 2002-04-01 15:53:37 EST
What version of chkconfig do you have installed?
Comment 3 ellson 2002-04-01 16:07:00 EST
# chkconfig -v
chkconfig version 1.3.4

(Why is run-level relevant?)
Comment 4 Bill Nottingham 2002-04-01 17:52:07 EST
Hm... was that version installed when you installed LPRng?
Comment 5 ellson 2002-04-02 08:40:20 EST
Judging by the timestamps on the rpms they probably arrived from the
Rawhide collection on the same day - Mar 18.

Probably I installed them in alphabetic order - i.e. LPRng first.

I just tried removing and reinstalling LPRng.  I got:
    # rpm -e LPRng
    /usr/bin/lpr.LPRng has not been configured as an alternative for print
    error: execution of %preun scriptlet from LPRng-3.8.9-2 failed, exit status 2

I tried replacing LPRng:
    # rpm -Uvh --replacepkgs LPRng-3.8.9-2.i386.rpm
    Preparing...                ########################################### [100%]
       1:LPRng                  ########################################### [100%]
    the primary link for print must be /usr/bin/cancel
    error: execution of %post scriptlet from LPRng-3.8.9-2 failed, exit status 2
Comment 6 Tim Waugh 2002-04-02 09:05:53 EST
LPRng-3.8.9-2 has 'PreReq: /usr/sbin/alternatives'.  Did you use --force when
installing LPRng?
Comment 7 ellson 2002-04-02 09:16:14 EST
No.  Perhaps that suggests that chkconfig was in fact installed first.

/usr/sbin/alternatives is there now, but attempts to remove and reinstall 
LPRng produce errors as above.
Comment 8 Bill Nottingham 2002-04-02 10:55:25 EST
It probably needs to prereq chkconfig 1.3.4-1 or greater, as the bugfixes that
went in are fairly significant.

What you should be able to do is to remove LPRng, remove
/var/lib/alternatives/print, and then reinstall LPRng.
Comment 9 ellson 2002-04-02 11:09:41 EST
    rm /var/lib/alternatives/print
    rpm -e LPRng
still didn't work because the %preun seems to expect a consistent state of the
system.  This is a bug IMHO.

This worked OK:
    rm /var/lib/alternatives/print
    rpm -Uvh --replacepkgs LPRng-3.8.9-2.i386.rpm


Now /usr/bin/lpr -> /etc/alternatives/print
and /etc/alternatives/print -> /usr/bin/lpr.LPRng
(a bit convoluted... but OK)
Comment 10 Tim Waugh 2002-04-02 11:41:39 EST
Alternatively you could have used --noscripts.

In 3.8.9-3 I'll put in a prereq for chkconfig >= 1.3.4-1.  We'll put it down to
chkconfig(alternatives) bugs in a version before that I guess.

Note You need to log in before you can comment on or make changes to this bug.