Bug 62343 - SEGFAULT in tcpdump-3.6.2-12
SEGFAULT in tcpdump-3.6.2-12
Status: CLOSED DUPLICATE of bug 62397
Product: Red Hat Raw Hide
Classification: Retired
Component: tcpdump (Show other bugs)
1.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-29 17:10 EST by Ricardo Ariel Gorosito
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 16:13:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
complete strace (4.72 KB, text/plain)
2002-03-29 17:12 EST, Ricardo Ariel Gorosito
no flags Details

  None (edit)
Description Ricardo Ariel Gorosito 2002-03-29 17:10:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020328

Description of problem:
when I do just "tcpdump" I get segmentation fault

How reproducible:
Always

Steps to Reproduce:
1.#tcpdump

Additional info:

Using kernel 2.4.18-0.12 (Athlon) & glibc-2.2.5-30

tail of strace:
open("/etc/nsswitch.conf", O_RDONLY)    = 4
fstat64(4, {st_mode=S_IFREG|0644, st_size=1750, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40014000
read(4, "#\n# /etc/nsswitch.conf\n#\n# An ex"..., 4096) = 1750
read(4, "", 4096)                       = 0
close(4)                                = 0
munmap(0x40014000, 4096)                = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
Comment 1 Ricardo Ariel Gorosito 2002-03-29 17:12:47 EST
Created attachment 51427 [details]
complete strace
Comment 2 Bill Nottingham 2002-04-01 16:13:19 EST
*** Bug 62397 has been marked as a duplicate of this bug. ***
Comment 3 Harald Hoyer 2002-04-02 04:10:53 EST

*** This bug has been marked as a duplicate of 62397 ***
Comment 4 Bill Crawford 2002-04-02 17:53:55 EST
Um, duplicate-bug-loop here?

Note You need to log in before you can comment on or make changes to this bug.